iOS 6 and IPSec VPN

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

iOS 6 and IPSec VPN

L4 Transporter

We have iPad 3's with IPSec VPN working with the Palo Alto 5020.  We upgraded one iPad from iOS 5 to iOS 6 and now the VPN is not working.  I know iOS 6 just officially came out this morning, but anyone else have this problem? Here's what I'm getting from a tail of the ikemgr.log...

2012-09-19 17:22:39 [INTERNAL_ERR]: decrypt output length does not match (976 != 984)

2012-09-19 17:22:39 [PROTO_ERR]: decryption 7 failed.

2012-09-19 17:22:43 [INTERNAL_ERR]: decrypt output length does not match (1248 != 1252)

2012-09-19 17:22:43 [PROTO_ERR]: decryption 7 failed.

2012-09-19 17:22:43 [INTERNAL_ERR]: decrypt output length does not match (976 != 984)

2012-09-19 17:22:43 [PROTO_ERR]: decryption 7 failed.

1 accepted solution

Accepted Solutions

The issue here is that in IOS 5 the IKE cert was not being fragmented but with IOS 6 it is being fragmented. So if the cert is large then this issue is seen. It seems be an issue on the Global protect not handling the fragmented cert correctly. Please open a case with paloalotnetworks support so this issue can be tracked and fixed. Please let us know if this helps.

Thank you

mbutt

View solution in original post

4 REPLIES 4

L6 Presenter

From the logs this looks like a buggy behavior and it seems like a known issue. can you please open a case with support to confirm this and guide you accordingly.

Thanks,
Sandeep T

I have the same problem with IPAD2 and iphone4 devices

The release software of our 4020 is 4.1.7

Thanks

Paolo

L1 Bithead

I also have the same problem when using certificates with IPSEC. I have an open case with support for this very issue. No resolution as of yet. I thought it was an MTU issue with the large certificate, but that was not it. We have had to revert to shared secrets on our IPsec gateways until this gets resolved.

The issue here is that in IOS 5 the IKE cert was not being fragmented but with IOS 6 it is being fragmented. So if the cert is large then this issue is seen. It seems be an issue on the Global protect not handling the fragmented cert correctly. Please open a case with paloalotnetworks support so this issue can be tracked and fixed. Please let us know if this helps.

Thank you

mbutt

  • 1 accepted solution
  • 3146 Views
  • 4 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!