Issue with VXLAN traffic passing through the firewall

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with VXLAN traffic passing through the firewall

L3 Networker

Hi Team, 

 

We have an SDWAN box placed behind the firewall and the SD_WAN box need to communicate with the controllers which is located on the internet.

 

The topology is given below:

SD_WAN Box<--->F/W LAN interface<--->F/W ISP interface <--> Internet <---->Controllers.

 

The SD_WAN Box is trying to establish VXLAN connectivity to the Controllers located on the internet.

 

On the traffic logs and the session browsers we could see the traffic flow b/n the  SD_WAN Box and the VXLAN is being allowed by the firewall and the application is being correctly identified as "VXLAN". 

 

We had configured only source NAT on the firewall but we could see on the log that the destination port is being translated to 511 from 4789

tamilvanan_0-1653585569659.png

 

Why the firewall is translating the destination port even though the DNAT is not configured. 

 

2 REPLIES 2

Cyber Elite
Cyber Elite

@tamilvanan,

Have you run a test nat-policy-match against the traffic to verify that it's actually hitting the NAT policy that you expect. IF the firewall is modifying the port, sounds like you're hitting a DIPP entry that you might not be expecting. 

L0 Member

What I have found is that the VxLAN Session information (both from the web UI and from the CLI using the "show session ..." output) is incorrect - or at least misleading. The first packet of the session is shown correctly, but all VxLAN packets after the start of the session are assigned to their own session with strange output. I'm not sure, but I think the strange output showed the destination information from *inside* the VxLAN traffic (even with tunnel inspection turned off!). Is it possible that 511 was the destination port inside the VxLAN traffic? A packet capture on the firewall opened in Wireshark shows that the firewall is forwarding traffic correctly.

 

I have a case opened with Technical Support to try to determine if there is a way to interpret the output or if it is simply a bug.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!