LACP Aggregate Group with Subinterface

Reply
Highlighted
L1 Bithead

LACP Aggregate Group with Subinterface

Hi everyone,

 

I'm trying to set-up a Subinterface on a Aggregate group with LACP on a PA-3020 and a DELL 6248 switch in a test envoirment.

 

If I assign an IP on the default VLAN to the Aggregate Group everything works but I can't seem to get the Subinterface to work, I've tested a Subinterface on a standard interface which also worked.

 

Below is the switch config for the 4 LACP ports, however I think the LACP side of things must be configured correctly for the Aggregate group to work when I assign it an IP?

 

Thank-you,

 

Kevin.

 

 

interface ethernet 1/g1
channel-group 1 mode auto
switchport mode trunk
switchport trunk allowed vlan add 1,180,200
exit
!
interface ethernet 1/g2
channel-group 1 mode auto
switchport mode trunk
switchport trunk allowed vlan add 1,180,200
exit
!
interface ethernet 1/g3
channel-group 1 mode auto
switchport mode trunk
switchport trunk allowed vlan add 1,180,200
exit
!
interface ethernet 1/g4
channel-group 1 mode auto
switchport mode trunk
switchport trunk allowed vlan add 1,180,200
exit
!

Highlighted
L7 Applicator

Hi Kevin

 

Did you set the subinterface tag to match with the VLAN ID in the trunk?

 

tags.png

Tom Piens - PANgurus.com
Like my answer? check out my book! amazon.com/dp/1789956374
Highlighted
L1 Bithead

Hi,

 

Yep, I set the tag to match, I've setup the Subinterface for the Aggregate group with the same settings I've tested on the Subinterface of the normal interface, interface1/7.180

 

It's a bit odd, I was expecting it to just work.

 

interfaces.jpg

Highlighted
L7 Applicator

Hi

 

You didn't set an IP address on the subinterface

Since this is a layer3 interface it requires an IP address.

 

If you want it to behave as a switched interface, you need to set the aggregate as a layer2 interface and then add a vlan with layer3 functionality

Tom Piens - PANgurus.com
Like my answer? check out my book! amazon.com/dp/1789956374
Highlighted
L1 Bithead

Hi,

 

Thanks for helping me with this!

 

I did have an IP set on the subinterface, it's displayed at the bottom of the screenshot.

 

I'd like the Palo to do the routing for the layer2 switches.

 

I've now changed ae1 to layer2.  I seem to be only able to add one VLAN per interface, so am I right in thinking I need to create a layer2 subinterface for each VLAN?

 

interface_ae1.jpg

 

Do I then create a VLAN interface for each VLAN?

 

vlan_interface.jpg

 

vlan.jpg

 

I've done the above but still no luck.

 

Thanks again for your help.

 

Kevin.

Highlighted
Cyber Elite

Dumb question but did you create the layer 2 vlan on the switch or did you only allow them on the trunk?

Highlighted
L1 Bithead

On the switch I have created the 180 VLAN, set-up an access port on VLAN 180 which I've plugged a test machine into and added the VLAN to the LACP trunk ports.

Highlighted
Cyber Elite

Ok. On your screenshots the AE seems to be up (->green icon), but is the LACP channel also up? What LACP settings do you have on the PA?

Is the spanning tree status "forwarding" on your switch in VLAN 180?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!