Manual software upgrade to 4.0.4 error

cancel
Showing results for 
Search instead for 
Did you mean: 

Manual software upgrade to 4.0.4 error

L3 Networker

I tried upgrading PA2050 to from 4.01 to 4.04.

But when I choose upload en the image file the PA starts uploading/checking the image and after a time I receive the error: Invalid Image.

Tried creating a new web server certificate and downloaded the image again but the outcome was still the error.

Then I decided to try upgrading to 4.03 and that succeeded.

Again tried upgrading to 4.04 but without succes.

BTW: I'am staging the appliances so I can't register them at the moment to try automatic installation.

12 REPLIES 12

L3 Networker

Issue is solved by using SCP with CLI.

You need to install a SCP server first somewhere.

scp import software from user@domain:/PanOS_2000-4.0.4
request system software install file PanOS_2000-4.0.4

L3 Networker

Problem solved.

Normally you would need to get the Management interface connected to your network so that it can contact updates.paloaltonetworks.com and retrieve the licenses. You need a valid support license to upgrade the software.

Steve Krall

We have the same issue. management interface is connected to the network, and licenses have been activated.

We were able to upgrade from 3.1.4 to 4.0.1 and from 4.0.1 to 4.0.3 but not to 4.0.4. 

We got the same invalid image message trying to upload the image file.

Seniornwb,

     This is a different issue.  The problem you are having is an upgrade path issue.  You must have the base image of a software release on your device to upgrade the SW.  To be specific,  to upgrade form 3.1.4 to 4.0.3, you must have 4.0.1(the base image) resident on the device.  You do not have to have it installed, just loaded on the device.  Once this base image is installed on the device, you can upgrade directly to 4.0.4.  Hope this helps,

~Jamie

Hi,

I think it is the same issue:

We were able to upgrade from 3.1.4 to 4.0.1 (the base image) succesfull without any problems,

We then tried to upgrade from 4.0.1 to 4.0.4 but it failed with "invalid image" message

We tried to upgrade from 4.0.1 to 4.0.3 -> succesfull

We tried again to upgrade from 4.0.3 to 4.0.4, again failed with "invalid image" message

The message invalid image appears when uploading the file to the device, not when trying to install it, so it seems there is some kind of checksum in the image that is not processed correctly.

Kind regards,

Hen

Hi,

Would you open a case? If the MD5 checksum is correct the manual upload should work.

Hi,

We checked the MD5 and downloaded the file twice. Two times the same result.

We are unable to create a case: "You do not have support to create case."

When I check support it says:

LevelPremium Partner
DescriptionPremium Partner
Expiration DateJuly 11, 2012

Is this normal ? Or is something wrong with the support registration ?

Kind regards,

Hen

Hi,

Case Management is accessible by customers with direct support through Palo Alto Networks.  You will need to open your case with the service provider with whom you have contracted for your Premium Partner Support. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!