Monitor aux ports through SNMP

Showing results for 
Search instead for 
Did you mean: 

Monitor aux ports through SNMP

L2 Linker

Is it possible to see the aux ports on a PA-5200 series firewall through the SNMP interface mib?  These are currently the interfaces that show up, the aux ports are not there.  This is on 9.1.11, PA-5250 to be specific.


ifName.1 = STRING: ha1-a
ifName.2 = STRING: ha1-b
ifName.3 = STRING: hsci
ifName.4 = STRING: mgmt
ifName.5 = STRING: ethernet1/1
ifName.6 = STRING: ethernet1/2
ifName.7 = STRING: ethernet1/3
ifName.8 = STRING: ethernet1/4
ifName.9 = STRING: ethernet1/5
ifName.10 = STRING: ethernet1/6
ifName.11 = STRING: ethernet1/7
ifName.12 = STRING: ethernet1/8
ifName.13 = STRING: ethernet1/9
ifName.14 = STRING: ethernet1/10
ifName.15 = STRING: ethernet1/11
ifName.16 = STRING: ethernet1/12
ifName.17 = STRING: ethernet1/13
ifName.18 = STRING: ethernet1/14
ifName.19 = STRING: ethernet1/15
ifName.20 = STRING: ethernet1/16
ifName.21 = STRING: ethernet1/17
ifName.22 = STRING: ethernet1/18
ifName.23 = STRING: ethernet1/19
ifName.24 = STRING: ethernet1/20
ifName.25 = STRING: ethernet1/21
ifName.26 = STRING: ethernet1/22
ifName.27 = STRING: ethernet1/23
ifName.28 = STRING: ethernet1/24


L4 Transporter

Thank you for posting question @howardtopher


Could you go to Device > Setup > Aux-1 / Aux-2 and make sure that these interfaces are enabled? In order the Aux-1 / Aux-2 interfaces to be enabled the IP setting has to be configured. After this, please run SNMP Walk again.


Kind Regards


Pavel Kucera

I have aux-1 enabled because that's the one I'm using.  I don't need aux-2 so it's not enabled.  The snmp walk that I ran was after enabling aux-1.  I ran it again just to be double sure, and aux-1 is not there.

L4 Transporter

Thank you for reply @howardtopher 


I see, thank you for confirmation. I have PA-5260 running 9.1.5 (AUX-1 is not in use). I was doing some research on this to find out more.


The AUX-1 port is referred as eth5.


> show system state filter { 'aux-1': eth5, 'aux-2': eth6, }


> show system state filter net.s0.eth5.*

net.s0.eth5.cfg: { 'disable-dhcp': True, 'fips-gated': True, 'hwaddr': 08:66:1f:02:7d:e2, 'ifindex': 7, 'ip-type': static, 'mtu': 1500, 'onboot': True, 'routes': { 'default': , }, 'table': aux-1, 'v6routes': { 'default': , }, }
net.s0.eth5.dhcp-dns: { }
net.s0.eth5.dhcp-ntp: { }
net.s0.eth5.dhcp-opcmd: 0
net.s0.eth5.dhcp-options: { }
net.s0.eth5.hwcfg: { 'advertised': [ ], 'link': Down, 'mode': Force, 'setting': 1Gb/s-full, }
net.s0.eth5.stats: { 'rx-bytes': 0, 'rx-compressed': 0, 'rx-drop': 0, 'rx-errs': 0, 'rx-fifo': 0, 'rx-frame': 0, 'rx-multicast': 0, 'rx-packets': 0, 'tx-bytes': 0, 'tx-carrier': 0, 'tx-colls': 0, 'tx-compressed': 0, 'tx-drop': 0, 'tx-errs': 0, 'tx-fifo': 0, 'tx-packets': 0, }


eth5 can be identified by Interface Index: 'ifindex': 7. By doing SNMP walk, I could see this interface to be showing up:


I know this is not perfect answer to your question, but if your monitoring system can monitor 'ifindex': 7, the it should be possible to monitor this interafce.


Kind Regards





Pavel Kucera

Interesting.  I checked the same commands on my firewall and it also shows ifindex 7.  However, when I do the snmpwalk or look in the monitoring system, ifindex 7 shows up as ethernet1/3.  It also shows "admin down" and "no connector", which is correct for ethernet1/3 as I'm not using it.  It's really strange. 🙂

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!