PAN Layer 2 and STP

cancel
Showing results for 
Search instead for 
Did you mean: 

PAN Layer 2 and STP

L3 Networker

I have a customer that is using RPVST+ on the core of their network for redundant Layer 2 connections to their servers. Using spanning tree link costs they load balance the trunked connections to their core switch. They have asked if it were possible to implement the PAN on one of those two trunked connections via Layer 2 subinterfaces and keep the per vlan spanning tree configurations. This would allow us to have automatic failover if the PAN went down and for troubleshooting/testing policies. 

Thanks for the help!

5 REPLIES 5

L4 Transporter

The PAN does not support spanning tree. You could use VWIRE and we would be a pass-thru. We would not participate in the STP communications and if the PAN failed, the link would go down causing STP to reconverge.

Steve Krall

I guess, I didn't really explain it well enough. I don't really need the PAN itself to participate in STP. Just the two core switches that have redundant layer 2 trunks links connected. One link would go through the PAN via Layer 2 subinterfaces and the second would bypass it. I would then set a link cost on the bypass link vlans and as long as the BPDUs are being forwarded through the PAN. It should work? Sorry this is pretty hard to explain.

I'm hoping to do excatly what you are talking about - if I think I understand correctly. Essentially you want the PAN to sit between two switches but have a concern that should it go down, a section of network would be isolated, so by having a second cable between the switches, but with a lower priorty, it would only get used when the path through the PAN is unavailable.

Can anyone confirm if this sounds sensible?

Yes, exactly.

Hey, I was able to test this out in my lab this morning and everything worked as expected! I was using Rapid-PVST on the switches and layer 2 subinterfaces for the VLANs on the PAN. I attached a screenshot of the network tab on the PAN for reference. Everything is layer 2. I'm pretty excited because this gives me a lot of flexability for testing/troubleshooting along with the added benefits of link failover.

Let me know if you have any questions.

2960-LAB

!

interface GigabitEthernet0/45

description PAN LAB TRUNK SECONDARY

switchport trunk allowed vlan 10,40

switchport mode trunk

spanning-tree vlan 10,40 cost 1000

!

interface GigabitEthernet0/46

description PAN LAB TRUNK PRIMARY

switchport trunk allowed vlan 10,40

switchport mode trunk

!

3560-LAB


!

interface GigabitEthernet0/41

description PAN LAB TRUNK SECONDARY

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,40

switchport mode trunk

spanning-tree vlan 10,40 cost 1000

!

interface GigabitEthernet0/42

description PAN LAB TRUNK PRIMARY

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,40

switchport mode trunk

!

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!