PanOS 10.1: DHCP server missing hostnames / descriptions

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PanOS 10.1: DHCP server missing hostnames / descriptions

L4 Transporter

PA220 running PanOS 10.1 managed via Panorama 10.1.

 

Prior to PanOS 5.something, you could not add a description to an IP reservation in the DHCP server configuration.  Later in 5.something, a description field was added.  This works.  You can add a description and see that description when looking at the DHCP Server configuration in Panorama or on the firewall itself.

 

However, the Description field actually used anywhere?

 

When looking at the DHCP Servers configured on a firewall in the web UI (Network tab --> DHCP --> DHCP Server sub-tab) it only shows the IP-MAC pair in the RESERVED column.  No Description.  There's no option to add the Description as a column.

 

When clicking on the IP POOLS column on the firewall itself, it brings up the active leases and reservations ... but the Description is not shown anywhere.  Again, there's no option to add the Description as a column.

 

If a dynamic pool is configured, looking at the IP POOLS shows the IP address assigned to a client MAC along with the client hostname, the lease time, etc.

 

However, if you reserve an IP for a specific MAC, the hostname field is blank!  Why?  The client still sends the same DHCP request to the server (including the client hostname), the server has the same info available as for a dynamic client, so why isn't the hostname shown?  Even worse, since the Description field for the IP reservation isn't shown, it's impossible to know which device is assigned which IP when viewing active leases!  All you have is a MAC address, no hostname, no description!

 

2 questions:

1. Why bother adding a Description field if it's never used anywhere?  This should either be part of the RESERVED column, or be usable as a separate column.

2. Why isn't the client hostname displayed for reserved IPs?  The DHCP server knows the client hostname.

1 REPLY 1

L4 Transporter

If I configure a dynamic range, then view the Allocations, it shows me the client hostname.

 

If I leave the dynamic range enabled, but reserve the allocated IP for a client, the client hostname disappears from the Allocations view.

 

If I remove the dynamic range, reserve the allocated IP for a client, and add a Description, it's not visible anywhere and the hostname field remains blank in the Allocations view.

  • 512 Views
  • 1 replies
  • 1 Likes
  • 101 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!