PanOS 9.1.11 (-h2) on PA-3020 cannot drive all physical ethernet interfaces except for management interface.

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

PanOS 9.1.11 (-h2) on PA-3020 cannot drive all physical ethernet interfaces except for management interface.

L1 Bithead

Does anyone know whether PanOS 9.1.11-h2 runs on PA-3020?


I have upgrade PanOS on PA-3020 to 9.1.11-h2, and the PA-3020 now cannot drive physical ethernet interface except for a management interface.


When I downgraded to PanOS 9.0.14-h3 or 8.1.20-h1, it came back to work again.


Here is a little debug out:


hoge@fw02> show interface hardware


Server error : An error occured. See dagger.log for information. 


hoge@fw02> show interface all


Server error : An error occured. See dagger.log for information.

hoge@fw02> tail mp-log dagger.log

Traceback (most recent call last):

  File "/usr/share/dagger/", line 463, in __str__

    return super(interface, self).__str__(*args, **kwargs) 

  File "/usr/share/dagger/", line 136, in __str__

    check_n_show(buf, s, len(slist)>1) 

  File "/usr/share/dagger/", line 109, in check_n_show, res)

  File "/usr/share/dagger/", line 317, in show

    show_ifhws (buf, res['hw']) 

KeyError: 'hw'


L1 Bithead

PanOS 9.1.10 also did not work while PanOS 9.1.9 worked well.

Cyber Elite
Cyber Elite


What version are you actually upgrading from when you attempted to do this, and what was your upgrade path. You shouldn't be jumping around major versions like what you described above, if an upgrade doesn't work a simple debug swm revert is the only thing you should actually need. 


The problem you are describing sounds like the autocommit didn't finish and your dataplane wasn't actually up yet, which would cause the behavior that you're describing. 

Thanks for your comments!!


I upgraded PA-3020 from 8.1.20 to 9.0.0, and then updated to 9.1.11-h2.

Should I have updated to 9.1.0 once?


BTW, I've confirmed the same phenomena on 9.1.11 and 9.1.10 while 9.1.9 and 9.0.14-h3 (downgraded from 9.1.11-h2) worked well.

In addition, with PA-5220, there was no problem at all with same upgrading path.

L1 Bithead

Also, 9.1.11-h3 and 9.1.12 with no luck.

  • 4 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!