SSL decryption and Http redirection

Showing results for 
Show  only  | Search instead for 
Did you mean: 

SSL decryption and Http redirection

L3 Networker


I am testing SSL decryption and it seems to work fine  except when Http redirection is involved. E.g. when you try to connect to Https:// , google redirects you to and it gives me a certificate error because of the hostname in the cert does ( in this case)not match with the hostname that you are connecting to ( originally).  Is there some way of working around this ? I am using PANOS 4.0.4.




L4 Transporter

Hi Sunil,

Have you tried to access other SSL site? Do you see the cert error?

Even you have been redirected from gmail to, our device should self-signed another SSL cert in realtime. I wonder if actually the error will show up even you are accessing other SSL site with SSL decryption enabled as well.

I agree sounds like your firewall certificate isn't trusted  If certificates are working should see no error   Another example is going to will will redirect to www and redirect to https  Remember with new browsers they also don't like device self signed certificates and you will likely need a pki or 3rd party

L3 Networker

Hi jleung,

Thanks for the response , I do not get the error when I access the other SSL webpages e.g., the firewall sigins and I can see it in the details.

The error on IE is as follows when I connect to Https://

The security  certificate presented by this website was issued for a different website's  address.

The following article says that 3rd party certs cannot be used.



Hi Sunil,

I think there maybe something wrong with your cert setting.

For SSL decryption to work, our box need to have either an imported or self generated CA cert. For 4.0.x, you need to go to device -> certificate to generate one. When you generate it, remember to check the box "certificate authority". After that please click on the cert that you have just created and choose "forward trust certificate". Make sure you have chosen "SSL forward proxy" in the option field of the decryption policy. Commit your change.

Now if you go to any of the HTTPS website, you should always see the cert error from the browser, and when click on the cert, you should see it is issued by the PA box.

Remember that we need a CA cert for SSL decryption to function, so that we can always enumerate the original website SSL cert on the fly. It doesn't bind to any websites. The browser will always show the error prompt though the cert cn name and expiry date are valid and matched, because the SSL cert is issued/signed by our box rather than any of the trust CA by Windows/MAC OS.

If you don't want to see the error prompt, you could leverage AD to install all the certs to your corporate PCs, or leverage your corporate CA server (if there is one) to create a subordinate CA cert and import it to PA box.

Using 3rd party signed cert (e.g. bought one from Verisign) can never help you, as those 3rd parties are selling you site cert but not CA cert. And we need CA cert which can sign certs.

L0 Member

Hi Sunil did you ever find out the answer to your question?

I'm running into the same issue on a project I'm working on due to a coworkers temporary incapacitation. If it go to I will get an error saying The security certificate presented by this website was issued for a different website’s address. If I view the certificate I see that by my PA-2020(which is a trusted root) however the certificate has been issued to hence the error because the browser is expecting to see a certificate for Figured I'd check the forums before opening a case



did you solved this issue?

we are running 4.1.6 and have simmilar poblems with gmail when it is redirected to the https url

SSL decryption has been running fine for most website but it's true is one of the few that is creating troubles.

can you tell me the reason ?

thank you

My opinion is the following : is hosted on same server than , to achieve that Google didn't create (for once) a multi SAN SSL certificate but relies on TLSv1 feature that allows Client and Server to negociate which certificate to use.

If client asks for, Server will present certificate, if Client asks during TLS negociation then Server will present certificate.

As PA seems to fails explicitly on those I have several theories:

  • PA doesn't support TLS certificate negociation when you ask it to decrypt so it will fallback to default presented certificate:
  • PA caches which certificate is associated to an IP (for performance benefits) and will reuse it next time you connect, whatever you are trying to negociate (until cache expires)
  • A mix of the above theories.


Today PAN Support confirmed me in a ticket : SSL decryption doesn't support SSLv3/TLSv1 fully : they clear original client HELLO packet to replace all values by their owns ones.

They even asked me to open a Feature Request... I hope it's the kind of ones they can implement "FAST" because I am relying a lot on Decryption which is a major feature that makes PAN ahead of others.

  • 10 replies
  • 101 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!