Trouble installing manually or from ISO on ESX

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble installing manually or from ISO on ESX

L1 Bithead

Have followed all the articles I can find.  Trying the ISO, I can login and basically gets stuck right after login at "initializing minemeld, this can take some minutes......", and left it for minutes/hours/days, just never finishes.  Tried canceling out and checking if its running and get some other errors about "no module named datetime".  Couldn't get the manual install to run.  Is tehre an easier way to get this running?  It seems like a lot of people are getting very different errors, so not sure what else to try.  This is where the ISO leaves off when checking.  Also tried removing the packages and re-adding, same results.


ubuntu@minemeld:/usr/bin$ sudo -u minemeld /opt/minemeld/engine/current/bin/supervisorctl -c /opt/minemeld/local/supervisor/config/supervisord.conf status
Traceback (most recent call last):
File "/opt/minemeld/engine/current/bin/supervisorctl", line 7, in <module>
from supervisor.supervisorctl import main
File "/opt/minemeld/engine/0.9.44/local/lib/python2.7/site-packages/supervisor/", line 36, in <module>
from supervisor.options import ClientOptions
File "/opt/minemeld/engine/0.9.44/local/lib/python2.7/site-packages/supervisor/", line 15, in <module>
import pkg_resources
File "/opt/minemeld/engine/0.9.44/local/lib/python2.7/site-packages/pkg_resources/", line 35, in <module>
import plistlib
File "/usr/lib/python2.7/", line 62, in <module>
import datetime
ImportError: No module named datetime


L5 Sessionator

Hi @Spetka,


the ISO image is not auto-contained. It is just an Ubuntu Cloud Image plus a cloud-init virtual CDROM providing the initialization script. This means that the VM in the ESXi must have direct (non proxied) connection to Internet for the script to download and install all dependencies.


From your message (No module named datetime) it looks like this initialization was not completed.


If you want a more contained install then you could give the MineMeld Docker image a try.

It has full non proxied internet connection.  The odd thing is that I can actually get to the webpage but when I enter the default credentials, I get a "Error checking credentials: bad gateway" error.  I found another person with same issue but that thread was unresolved.  So it seems partly installed, just not fully functional.  But uninstalling reinstalling doesn't seem to help. 

@Spetka, any relevant log message in /var/log/cloud* or /var/log/minemeld* ?

I see some errors about no instance datasource, such as :


2018-03-01 10:35:40,118 -[WARNING]: No instance datasource found! Likely bad things to come!
Cloud-init v. 0.7.5 running 'init-local' at Fri, 02 Mar 2018 04:41:07 +0000. Up 3.79 seconds.

tried on 16.0.4 Ubuntu with the ansible playbook, same issue.


File "/opt/minemeld/engine/0.9.44/local/lib/python2.7/site-packages/pkg_resources/", line 35, in <module>
import plistlib
File "/usr/lib/python2.7/", line 62, in <module>
import datetime
ImportError: No module named datetime


Is there a way to change the password for the admin on the webgui?  Maybe I can get in that way?

@Spetka you're not deataching / disconnecting the virtual CDROM from the VM after installation, do you?

L1 Bithead

Hi Spetka


I had the same problem using the ESXi ISO and the ansible playbook, but all for Ubuni v.16.04. Th eonly way I could get this working was to use v14.04. Even once I Hardened the instance, installed updates, imported the o365 Minemeld config, created recommended security policies, changed passowrds (all working as expected) I logged in today and there was an advisary to upgrade to 16.04, so I took a snapshot and folowed the prompts and lo and behold, back to the same "No module named DataTime".


So, maybe not the best idea, but I'll keep this running on v.14.04

  • 7 replies
  • 101 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!