Unable to export certificates
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to export certificates

L2 Linker

PanOS 7.0.1

 

Tested with Google Chrome and Firefox v56

 

When trying to export a certificate from Device tab --> Certificate Management --> Certificates, no matter which export format I choose, nor which certificate I choose, nothing happens.  Browser window just refreshes and reloads the certs page.  Nothing is downloaded.

Has this ever happened to anyone else?  Any idea why it would be happening?  Or is there any way to export from CLI

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

L7 Applicator

I have never had this issue in both firefox an ie.

 

i did find this cli for scp.

 

scp export certificate to <value> remote-port <1-65535> source-ip <ip/netmask> certificate-name <value> passphrase <value> include-key <yes|no> format <pem|der|pkcs12|pkcs10>

 

I have never used it though......

 

or an API call may help...   more here...

https://docs.paloaltonetworks.com/pan-os/9-0/pan-os-panorama-api/pan-os-xml-api-request-types/export...

 

View solution in original post

4 REPLIES 4

L7 Applicator

I have never had this issue in both firefox an ie.

 

i did find this cli for scp.

 

scp export certificate to <value> remote-port <1-65535> source-ip <ip/netmask> certificate-name <value> passphrase <value> include-key <yes|no> format <pem|der|pkcs12|pkcs10>

 

I have never used it though......

 

or an API call may help...   more here...

https://docs.paloaltonetworks.com/pan-os/9-0/pan-os-panorama-api/pan-os-xml-api-request-types/export...

 

View solution in original post

Hello,

I agree on trying another browser. Also flushing all temp files from Chrome is a good idea.

 

Regards,

@OtakarKlier @MickBall there is a bug with PAN OS 7.0.1 while exporting Certificate with other browser to fix this  OS need to update but you can export the certificate with Microsoft Internet Explorer

Great! It worked with Microsoft Edge since the host vm is a Windows 10.  This is what I expected Firefox and Chrome to be able to do.  The PAN OS 8.0.0 apparently has the same bug.  Anyway, thanks very much for this.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!