URL-filtering response page URL variable

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

URL-filtering response page URL variable

L2 Linker

The URL returned on the filtering response page substitutes underscores ("_") for forward slashes ("/") in the URL.

ie. I go to "www.blockedsite.com" it tells me "www.blockedsite.com_" is filtered. &  "www.blockedsite.com/index.html" becomes "www.blockedsite.com_index.html" etc

I've created a custom response page that a inludes a pre-populated link to Brightcloud's recategorisation site but using the <url/> variable the field gets populated with this invalid URL - any ideas?

1 accepted solution

Accepted Solutions

Hi Liam,

This was a bug that was recently addressed.  You should see the fix in an upcoming release.

--Doris

View solution in original post

6 REPLIES 6

L6 Presenter

What version of PAN-OS are you running?  It appears to be a bug and you may want to open a support case.  Thanks.

we're using 4.1.2 - I'll try 4.1.3 before logging it as a bug.

Liam,

Were you able to get it working after the upgrade to 4.1.3?  Also, can you provide an example of the code modifications that you made to the response page?  I also recommend checking out the DevCenter that has additional resources for customizing the device: < https://live.paloaltonetworks.com/community/devcenter >

-Graham

Hi Liam,

This was a bug that was recently addressed.  You should see the fix in an upcoming release.

--Doris

thanks

Interesting - I opened up a support case about this very issue but appearntly they're still researching the problem or think it's being caused by a security rule that PAN is applying.

Currently being experienced when users attempt to go to www.foxnews.com or www.bing.com. Entering in the URL's without the "www." works just fine and presents a CP page for people to authenticate against (using standard block page). Traffic that is from unidentified users is supposed to be CP'ed - the block page with the underscores instead gives the computers IP as the user id and does not prompt for CP.

Running 4.1.3.

  • 1 accepted solution
  • 4445 Views
  • 6 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!