USER-ID littered with pc HOSTNAME@DOMAIN.COM

Reply
Highlighted
L3 Networker

USER-ID littered with pc HOSTNAME@DOMAIN.COM

While looking through logs to see why occionally a user gets reported as user@domain.com instead of domain\user, we noticed the logs were filled with COMPUTERHOSTNAME@DOMAIN.COM as well.  Is this expected?

Tags (1)
L4 Transporter

Re: USER-ID littered with pc HOSTNAME@DOMAIN.COM

@OGMaverick: Please check which user id source is providing that format

show user user-id ip-usermapping all | match <user | ip>

I guess you got the Authentication profile for that source mixed up - it's the following settings:

2019-02-27 09_33_32-10.44.3.41 - Remote Desktop Connection Manager v2.7.png

Highlighted
L3 Networker

Re: USER-ID littered with pc HOSTNAME@DOMAIN.COM

Auth profile is correct & the user with the computer hostname never shows in the traffic/url logs or in the CLI when I did a show user ip-user-mapping all.  It's like the PCs are passing the hostname to the DCs as the username from time to time.  Grabbed a small snippet of the user-ID logs to show what I'm talking about.  When this happens, the user appears in traffic logs as user@domain.com until they reappear into user-id the correct way. Top 2 are normal and have the username.  Second two are showing PC hostname.  All from the same source.  Would love to stop the bottom 2 from happening

 

PAN-LOG.png

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!