Getting Set VSYS message when creating Panorama certificates

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

Getting Set VSYS message when creating Panorama certificates

L0 Member

I am creating a certificate/CSR for my management TLS login.  I created a cert, but when going to export the CSR, or anything else on the bottom bar, I get a hovering message "You need to assign a default VSYS to current template first"  I can't find anywhere in Panorama to set the VSYS, all my device templates have VSYS1, Tried many documents, search phrases, even exact pop-up, but can't seem to find the answer.


Thanks in advance.


L3 Networker

You can check the vsys options over here in panorama GUI



Best Regards,

Hello Shuresh,  Thanks for the response.  That will get me certs for the firewalls, but I need a cert from a private CA for the management interface of the Panorama.  I am still looking online, but haven't found the solution.  The add cert section of the Panorama manual talks about it, but the add cert starts at the section you indicated.  I even tried to create a shared cert in the device section, but it doesn't show up in the Panorama section.

L0 Member

I have the exact same problem as the above whilst trying to generate a cert for Panorama itself (not the firewalls). Did you find a fix for this ?

  • 3 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!