When I run Terraform Apply, it says resource already exists

Announcements
Attention: The LIVEcommunity is experiencing an interruption with videos in some areas. We apologize for any inconvenience this may cause. Thank you for your patience as we work towards a solution to restore videos.
Reply
Highlighted
L0 Member

When I run Terraform Apply, it says resource already exists

When I try to run Terraform apply, it throws errors saying Resource X already exists, Should it not read the state from s3 bucket and see that the resource has already been created? 

Highlighted
L4 Transporter

Re: When I run Terraform Apply, it says resource already exists

If something already exists but it does not yet exist in the local state, then you want to import that resource, assuming the resource can be imported.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!