Completely silent XDR install command line switches.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Completely silent XDR install command line switches.

L3 Networker

Looking for some insight on how to automatically accept the license during agent installation.


L2 Linker

Something similar to the below command?

wget -O dockerimages.tar ""

Thanks, I suppose I should have mentioned it is the Windows 64bit package and I am using msiexec switches.

My bad for not clarifying.

And I tried Accept_Eula=1 as well.  I wonder if a transforms would do the trick.

@PC-TomS wrote:

And I tried Accept_Eula=1 as well.  I wonder if a transforms would do the trick.

What about ACCEPTEULA=1?


Nope, same error 1603.  I dug in to the MSI and there is a LicenseAccepted property that must return a value of '1' for the install to continue.
I'm a bit rusty on my MSI so I was hoping someone else had the same issue.




L2 Linker

So this is a wild solution someone tried for something similar: 

Instead of creating a new transform and applying it through GPO i edited the msi directly then added it to the GPO.

Using Orca, opened the downloaded .msi file and add an entry to the 'Property' table.

Property = ACCEPT_EULA

Value = 1

Sadly, it is not in the property table but there are references in several other tables.


It is also not a EULA afaik.  That is typically used for Microsoft products. 


There are several references to the license dialog throughout the msi and I am not versed enough to figure out which ones to change.



I appreciate you trying to help and I have reached out to our support team and may open a case if that doesn't work out.



Oh yeah, I tried what you posted too.

Yes, I tried all the switches in the documentation and many others.

L1 Bithead

hey @PC-TomS ,

this has worked for me

msiexec.exe /i cortex.msi /qn


hopefully this helps.

L5 Sessionator

Hi @PC-TomS can you please share some screenshots when you try to install with the '/qn' switch? The '/qn' switch is for silent installations.



/qn did not work for me but /passive did.


When I used /qn I got a 1603 error and the log showed that the AcceptLicense did not = '1' and it failed.


Thanks for all the suggestions.

  • 13 replies
  • 78 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!