How to automatically input the password when using the "cytool reconnect" command?

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

How to automatically input the password when using the "cytool reconnect" command?

L1 Bithead

Hi everyone,

I want to run Cytool reconnect on multiple computers, 

I tried the following

 

 

echo <password>| cytool reconnect force

 

 

it works, but still displays "Enter supervisor password:", so you still need to press enter to let it continue running.

Chilla_0-1686708588184.png

 

 

is there another way to pass the password to cytool via cmd? Or make it not display "Enter supervisor password:"
Thanks!

 

 
 
1 accepted solution

Accepted Solutions

L3 Networker

Hi @Chilla 
May I know what is the agent version you are using?
Make sure you are running the command with administrator privileges.
I'm able to execute same command.
I have also tried different ways.
cytoolreconnectforce1.png
Can you try different ways to execute the command as shared above and see if it helps.



I hope that answers your query.

Please mark this as answer if you found it helpful.

View solution in original post

7 REPLIES 7

L3 Networker

Hi @Chilla ,

The correct format to run the command is as below
echo <password>|cytool reconnect force

I see you have provided space after pipe which is why you are getting prompt to enter password.
Remove the space after pipe and it should work.
I have tried to execute same, and it worked for me, please find below.cytoolreconnectforce.png

I hope that answers your query.

Please mark this as answer if you found it helpful.


Hi @creddy ,

Thank for your response.

I try your command, it still getting prompt to enter password.

But it allows me to skip the situation where I need to press the Enter key to continue running.

Chilla_0-1686712554334.png

 

L3 Networker

Hi @Chilla 
May I know what is the agent version you are using?
Make sure you are running the command with administrator privileges.
I'm able to execute same command.
I have also tried different ways.
cytoolreconnectforce1.png
Can you try different ways to execute the command as shared above and see if it helps.



I hope that answers your query.

Please mark this as answer if you found it helpful.

L1 Bithead

Hi @creddy 

Thank you for your response.

My agent version is 8.0.1, and I also  running the command with administrator privileges.

I tried both commands you provided.

Although they don't require pressing Enter during execution, there will still be a prompt asking for password input.

Chilla_1-1686722751334.png

 

 

L3 Networker

Hi @Chilla ,

May I know if you don't require pressing Enter during command execution, how the command being executed and showing prompt to enter password? You must need to press enter for executing any command in command prompt.
If you are copying command from somewhere and pasting, you might not need to press enter I believe.

May I ask further details to know better.
1.Is your agent supervisor password correct? If you are not sure about whether password is correct or not, you can change to new password from agent settings profile or you can use token password. 
For more details about agent setting profile, refer step 7 in Add a New Agent Settings Profile 
For more details about token password, refer Manage Agent Tokens
2.Is your agent able to connect XDR cloud servers and showing as connected in XDR console?

3.Can you perform checkin on agent console and see if it works?

If everything is ok, restart the machine once try to execute the same command.

Hi @creddy ,

Thank you for raising your concerns.

Sorry, probably I didn't explain it clear enough and caused your misunderstanding.

What I mean is that when the prompt to enter the password appears, there is no need to enter the password or press Enter to continue running the command.

Chilla_0-1686808498857.png

  1. Is your agent supervisor password correct? 
    → Yes. I have tried to run cytool in the standard way and entered the supervisor password, which is correct. Then I check my agent setting to comfirm it's same password.
  2. Is your agent able to connect XDR cloud servers and showing as connected in XDR console?
    → Yes, It's connected to XDR Console
  3. Can you perform checkin on agent console and see if it works?
    → It's works!
    Chilla_1-1686809951886.png

     

 

L3 Networker

Hi @Chilla ,
From the screenshot you provided, I can see that cytool reconnect force command executing as expected.

Since you are giving the password input in advance in the command, you don't need to key in password or press enter when it ask for password.
The command automatically accepts the password from the command line as we have already inserted it.
That is the reason you don't need to enter password separately when you use this format.
In summary I can say the command executed successfully.


I hope that answers your query.
Please mark this as answer if you found it helpful.
Thank you!

  • 1 accepted solution
  • 1770 Views
  • 7 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!