Enable Communication Tasks

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enable Communication Tasks

L3 Networker

Hello all


I'm trying to activate the Communication Task.

The Idea is, that User may answer without to have a xsoar account.

So far, I found this Doc:


I've entered both settings into troubleshooting.

the d1.conf file looks like:


the rights of the file looks like:

-rw-r--r-- 1 demisto demisto 26 Jun 29 10:08 d1.conf


I've restarted demisto - but do not see any port 8080 on "ss -tulpen"


What is wrong on my side? What did I overseen?





L2 Linker

I understand that port 8080 isn't in the output of that command. Just to verify, after adding the server config and the d1 config, users are still unable to access forms sent out in communication tasks, correct? 


As far as I untersood is, that I need first a running communication Task, before I may use it in any Playbook.

And I don't think, that this communication-Port is the same port as demisto for admin is running on it (https/443)

So I choose a different Port. 

And no, that port (8080) is not in the open ports list of "ss", looks like, demisto is not opening it.




Please verify that there's a colon in front of the port number. Let me know if I should further explain any of the following commands


Display current conf

sudo grep BindAddress /usr/local/demisto/d1.conf


Replace line in conf

sudo sed -i 's/BindAddress.*/BindAddress": ":8080",/' /usr/local/demisto/d1.conf


Verify new conf

sudo grep BindAddress /usr/local/demisto/d1.conf

Restart XSOAR engine service

sudo systemctl restart d1


Verify listening port

ss -tulpen | grep 8080



Hello Atullo


Indeed, I did not hat the colon in the config - could you please take care, that this little info gets into the document in my thead opening?


How ever, I did all your steps, but system could not find d1.service, I tried first with demisto.service then with a reboot - still no port 8080


(btw, I like the -tulpen, use it since years 🙂 )




Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!