Issue with Commit-all API in Panorama

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

Issue with Commit-all API in Panorama

L0 Member

We are trying to implement the Commit-all feature in our product, and use the api mentioned in the document i.e 

 
curl -X GET 'https://<panorama>/api/?key=apikey&type=commit&action=all&cmd=<commit-all><shared-policy><include-template>no</include-template><device-group><entry name='<device-group-name>'/></device-group></shared-policy></commit-all>'
 
Expected Behaviour: 'Commit and Push'
Actual Behaviour: Commit
Now actually only commit is working but 'commit along with Push' action is not working.
Attaching the screenshot of the expected behaviour for your reference.
 
Commit-all issue description:
 
I performed the orchestration action from USMA, selected 'Add Address to Address Group' action and the Device Group as 'PA-VM-device-group'. (refer screenshot: Orchestration action.png)
 
When I check the panorama environment I am able to see that the device group selected during the orchestration action will be still pending for a manual push(refer screenshot: commit-all.png) but commit-all api will be invoked. Confirmed that by using the 'Tasks'' (refer screenshot: task.png) option available in the panorama environment.
 
Regards,
Savitha G.
 
 


Please note you are posting a public message where community members and experts can provide assistance. Sharing private information such as serial numbers or company information is not recommended.
1 REPLY 1

L1 Bithead

@Savitha Panorama Charter Home wrote:

We are trying to implement the Commit-all feature in our product, and use the api mentioned in the document i.e 

 
curl -X GET 'https://<panorama>/api/?key=apikey&type=commit&action=all&cmd=<commit-all><shared-policy><include-template>no</include-template><device-group><entry name='<device-group-name>'/></device-group></shared-policy></commit-all>'
 
Expected Behaviour: 'Commit and Push'
Actual Behaviour: Commit
Now actually only commit is working but 'commit along with Push' action is not working.
Attaching the screenshot of the expected behaviour for your reference.
 
Commit-all issue description:
 
I performed the orchestration action from USMA, selected 'Add Address to Address Group' action and the Device Group as 'PA-VM-device-group'. (refer screenshot: Orchestration action.png)
 
When I check the panorama environment I am able to see that the device group selected during the orchestration action will be still pending for a manual push(refer screenshot: commit-all.png) but commit-all api will be invoked. Confirmed that by using the 'Tasks'' (refer screenshot: task.png) option available in the panorama environment.
 
Regards,
Savitha G.
 
 


Please note you are posting a public message where community members and experts can provide assistance. Sharing private information such as serial numbers or company information is not recommended.

I additionally went confronting a fundamentally vague issue at any rate whatsoever point it is agreed to me. Much appreciation to you for the help.

  • 1818 Views
  • 1 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!