Duplicated objects with same name but different mask

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements

Duplicated objects with same name but different mask

L0 Member

Hi All,

 

I need help with this tricky thing. It looks like a bug though.

I have 200+ duplicated objects (in pairs) with same name, but different mask (obviously wrong on the duplicate item).

E.g.,

subnet A - 10.0.0.0/16

subnet A - 10.0.0.0/32

The config was digested from ASA 9.14.

Expedition version: 1.2.87

I've checked ASA for duplicates and there are none.

Example screen attached.

 

I wonder if anybody can advise how to fix it.

 

Kind regards,

Paul

1 accepted solution

Accepted Solutions

L4 Transporter

Hi @pavel.zemtsov 

 

Please consider update to latest version 1.2.91 as it contains a fix issue for address merge feature.

 

Also consider executing this workaround as my guess is that although both objects are showed as used only 1 of them is currently being used.

Please follow below steps to test my assumption:

- Get the object  "A - 10.0.0.0/16" named  "A - 10.0.0.0" and rename to "A - 10.0.0.0_16".

- Execute the calculated unused objects.

- If I'm not wrong one of the objects will be displayed now as not used so you can just remove it.

 

To do above for all your objects you can create a filter and using the tools tab add a suffix to the selected objects.

Let me know if that could help,

 

Note: To work on a final fix I will need you share your original configuration with us using a TAC case. If you do so please send an email to fwmigrate@paloaltonetworks.com with the TAC case number.

 

Thanks in advance,

 

David

View solution in original post

2 REPLIES 2

L4 Transporter

Hi @pavel.zemtsov 

 

Please consider update to latest version 1.2.91 as it contains a fix issue for address merge feature.

 

Also consider executing this workaround as my guess is that although both objects are showed as used only 1 of them is currently being used.

Please follow below steps to test my assumption:

- Get the object  "A - 10.0.0.0/16" named  "A - 10.0.0.0" and rename to "A - 10.0.0.0_16".

- Execute the calculated unused objects.

- If I'm not wrong one of the objects will be displayed now as not used so you can just remove it.

 

To do above for all your objects you can create a filter and using the tools tab add a suffix to the selected objects.

Let me know if that could help,

 

Note: To work on a final fix I will need you share your original configuration with us using a TAC case. If you do so please send an email to fwmigrate@paloaltonetworks.com with the TAC case number.

 

Thanks in advance,

 

David

Hi @dpuigdomenec ,

 

Thank you for the detailed and fast reply.

I'll update the Expedition first and report the output here.

 

Kind regards,

Paul

  • 1 accepted solution
  • 839 Views
  • 2 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!