Verify the DataBase settings are valid Error

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

Verify the DataBase settings are valid Error

L1 Bithead

Hello, I'm on version1.1.103 of Expedition and I am unable to remediate this error: "Your database is listening for incomming connections from only '127.0.0.1:3306' (IP:port)
Remediation: Verify you have proper settings for database connections. (see ML gets stuck at "Pending" )'

 

When I select their recommended remediation instructions and try to follow the steps, /etc/mysql/my.cnf file doesn't have the field for bind-address at all and I checked all the other db files and couldn't find it either. How can I go about getting this resolved? What is supposed to be set?

 

Thanks

16 REPLIES 16

L6 Presenter

Hi @aalaridRF Try restart the mysql service by issuing below commands:

sudo service mysql restart

 

I tried a restart and a full stop/start of mysql and still no difference. Here's what shows up in the my.cnf through vi:

aalaridRF_0-1626796926322.png

 

@aalaridRF  Please try to change the IP address to 127.0.0.1 and click on save.  when you navigate to other tab and come back , it should show the expedition real IP in the field instead of the 127.0.0.1. 

 

Screen Shot 2021-07-20 at 9.21.26 AM.png

Changed to the loopback address, saved, and then switched tabs. Came back and it changed back to the real IP that it was before. Still shows the same error on the Dashboard after rescanning. Tried opening the my.cnf again and now I get this screen: 

aalaridRF_0-1626802799128.png

Even tried restarting the mysql service again.

L1 Bithead

Is there anything else I can try? Just updated to the latest beta and still no change.

Hello @aalaridRF 

 

Once you change it to 127.0.0.1 go ahead and hit the save button located at the bottom right of the page. Most likely you may not have done that so it can save the new updated IP address.

Thanks for the post. Save was definitely clicked, got the Data Saved popup afterwards but when I change tabs and click back into Settings > M.Learning the IP has reverted to the previous IP. Is there anywhere else I need to change the IP?

Are you reaching expedition with a NAT'd IP address? If so reference the IP address prior to being NAT'd, alter it to the IP address of the expedition server and see if anything changes. That IP address should be located within the CLI "ifconfig | grep inet".

IP address isn't NAT'd, it is the same IP I get when I run the ifconfig. I see both the assigned IP and the 127.0.0.1 listed for inet.

Hello @aalaridRF 

 

When you log into your expedition server what IP address does it show at the top?

L2 Linker

Hello,

I am on version 1.2.70 and I have same error message:

 

Your database is listening for incomming connections from only '' (IP:port)
Remediation: Verify you have proper settings for database connections. (see ML gets stuck at "Pending" )

 

But according to the mysql it is ok.

LukasB_0-1692196235579.png

 

However, if I try to import config from CISCO, it is freezed on "initializing".

LukasB_1-1692196620493.png

 

Hi @LukasB Please verify if the agent is up and running, you can go to dashboard and it should show you agent status , if it's down, trying to restart it . 

L1 Bithead

anyone figure out how to fix this error?

Hi @marianneogorman 

 

Try to locate file /etc/mysql/mariadb.conf.d/50-server.cnf and comment line bind-address.Then restart the mysql service.

 

If the issue persists please send and email to fwmigrate@paloaltonetworks.com

 

Hope this helps,

 

David

  • 5274 Views
  • 16 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!