Authentication using LDAP/AD

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Authentication using LDAP/AD

Not applicable


I'm trying to get LDAP authentication working using Active directory. I have created an LDAP server profile, an Authentication Profile and Group Mapping settings profile. When I'm setting up the Group mappings I can go in and see the entire directory tree and pick groups so I know that it is connecting the the AD server and pulling information. However, in the Authentication Profile, if I try to pick users for the allow list, it doesn't find anything from the AD only local users. I have tried creating a firewall Administrator using the LDAP profile, and cannot login. When I look at the system log, it says "authentication profile not found for user".

I'm obviously missing something somewhere, but can't figure it out.




L6 Presenter

Hi...Within the Authentication Profile, please make sure you set the authentication=LDAP and set the Server Profile=<LDAP server>.  Then select 'all' for the Allow List.  Please give that a try.  Thanks.

Thanks @rmonvon but those are the settings I currently have.


If you have 'all' selected under the Allow List, the authentication should work on all users.  There is another post where some users could not get the group listing to display.

Maybe you can check back on this other posting to see the result once they have contacted support.  Thanks.

Thank-you for the link. There is a suggestion in that thread that this might be a bug in 4.1.2 (which we are running). Has it been determined that it is a bug?


Yes, it has been identified as a bug and is targeted to be fixed in the next release, 4.1.3. The workaround is to set the Allow List to 'all' under the Authentication Profile and define a Security Rule to allow access only to the specific AD group.  Thanks.

Thank-you. Should this workaround work for device Administrators as well? Because it doesn't. I haven't tried it with the Portal and VPN because I don't want to break our currently working configuration. However, when I try to add an Administrator using the same LDAP profile it will not authenticate users in AD.


The bug is not allowing the AD groups to be displayed for you to select from.  So leaving the Allow List='all' at default should work for admin authentication.  I suggest that you delete the Authentication Profile that is not working and create a new Authentication Profile.  Make sure to set the authentication=LDAP, select the LDAP server, and the login cn=sAMAccountName if this is an AD LDAP.

Still no luck. Attached is screenshot of my config. Error in system log says "authentication profile not found for the user from: <IP Address>.

Can you check the admin account setting please.  The error appears to indicate the admin setting is missing the authen profile.  If it looks correct and the problem persists, please contact support.  Thanks.

Yes the profile is there. I'll call support.




did you get this working?  im having the same issues.

No I haven't. I haven't called support yet because the real thing I'm trying to get to work is the AD authentication for the VPN and there is a bug in that. So I figured I'd just wait until they fix the bug. Hopefully that wil be relatively soon.


Having similiar issues at a customer.

@smithkopel - Did you manage to get this issue resolved?


No I haven't worked on it any more. I intend to upgrade to a newer version of the OS in a couple of weeks and hopefully that will fix the root of the problem.


  • 17 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!