Cannot install Machine Certificate for GP Pre-logon

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot install Machine Certificate for GP Pre-logon

L4 Transporter

I encountered a problem installing the machine certificate.


I followed the article below:
We are using a self-signed root ca that is in the cert profile for auth, then generated the server cert and machine cert and signed them with the same root. Then export as pks12.
In the Certificate Profile, I changed the Username Field type from 'None' to 'Subj'.
Made sure I selected the Computer account (default is user account) and cert is in folder "Personal" there.
Tried the MS fix but no luck.
Please help!

something seems to be wrong with your configuration as when I log off my workstation the existing (not previous) connection changes to pre-logon and reverts to my name when i log back in.


can you post exactly what you have in the gateway config...




















Thank you so much for your guidance.

I checked the GP GW config and removed the cert from Certificate Profile. It worked!


May I ask what was the problem?


Cert Profile.png

I cannot really tell without seeing your complete setup but it may be that as you included the certificate in the profile, GP was seeing pre-logon as a separate user rather than just a pre-logon user.


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!