DNS Proxy doesn't work

Announcements

ATTENTION Customers, All Partners and Employees: The Customer Support Portal (CSP) will be undergoing maintenance and unavailable on Saturday, November 7, 2020, from 11 am to 11 pm PST. Please read our blog for more information.

Reply
Highlighted
L0 Member

DNS Proxy doesn't work

Hi,

I configured dns proxy like have been deescribe on palo-alto but it doesn't work at all.

I made this steps:

1 - enabled dns proxy on l3 vlan interface

2 - set two dns servers to use

3 - enabled cache

But i don't see anything in dns proxy cache.

Maybe i forgot something?

Tnx

Answer

Highlighted
L6 Presenter

have you changed your dns setting on the clients and map them to l3 interface ip ?

Highlighted
L6 Presenter
Highlighted
L0 Member

Yes and still doesn't work.

Do i need to make special security policies for that?

I use Captive Portal too.

Highlighted
L4 Transporter

Sounds like you didn't create any DNS Proxy rules.

Highlighted
L6 Presenter

Clients will make dns lookup using the interface(ip) you enabled.I don't think you have a deny rule for that but check to be sure.

can you check output of that also :

show dns-proxy statistics all

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!