Failed to install licenses. Model incompatible: feature model is VM300 while the device model is PRA

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

Failed to install licenses. Model incompatible: feature model is VM300 while the device model is PRA

L1 Bithead

Hello all,

   I have just setup a Palo Alto firewall virtual instance.  I have the interfaces setup now so that I can download updates/content.  I attempted to apply my license using the authorization code.  The first time that I tried I got an error that I needed a minimum of 6.5 GB of memory, so I shutdown the VM and changed it to 4vCPU and 8GB RAM.  When I bring it back up and try again, it says I have exceeded the auth code use count.  And when I select to retrieve license keys from the license server, I get the error  "Failed to install licenses. Model incompatible: feature model is VM300 while the device model is PRA"


Any ideas?


Thanks in advance,



Cyber Elite
Cyber Elite


You sure you used the right image to spin up the VM? PRA would be Panorama

I believe that this is the correct one.  It was provided to me.  The file name is "PA-VM-ESX-8.1.0.ova" and the GUI and CLI operate like I expect the firewall to.



Hi @PFerris,


Can you try uploading the license manually as per the steps in this guide?




I think my Auth code is invalid now since I tried it one and that is when I received the initial error.  I'll request a new one.

Thanks for the link.




Just FYI. 8.1 is pretty early in it's life cycle and isn't somethign that I would recommend that you run on production equipment just yet. However if you choose to do so please update to 8.1.2 to address a wide variety of issues that have been fixed since 8.1's initial release. 

You may also be running into PAN-97003, earlier versions of 8.1 had a known issue where they wouldn't actually display the licenses even if you were able to activate them. However it does sound like you are probably running into a different issue. 

L3 Networker

In case somebody else ran into this issue, I was able to resolve the issue by loading the Licensing API key from the support portal into my AWS firewall then fetch the license using the auth-code:

request license api-key set key YOUR_LICENSING_API_KEY
request license fetch auth-code YOUR_CAPACITY_LICENSE_AUTH_CODE

NOTE: The licensing API key can be found under Assets > Licensing API in the support portal

After the second command, you will be disconnected from VM. Upon reconnection you should see that you are licensed. Loading the Licensing API key may or may not be necessary, but the firewall should of course have internet access (incluing DNS) from it's MGT interface.

Thanks for the info.  I'm in a weird position where I cannot get a support account tied to my company.  I'm going to talk to my rep and see if I can get a "personal" support account?


Of course it would be best if you have your own support account if you're responsible for supporting the Palo Alto Networks solutions at your company, but in the event you can't get an account for some reason, you should still be able to get the licensing API key from any of your colleagues that have a support login there.

  • 8 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!