I am having Pan-OS integarted user Id

Showing results for 
Show  only  | Search instead for 
Did you mean: 

I am having Pan-OS integarted user Id

L1 Bithead

For some reason the Agent stopped working on the end user computer. when i checked the event log i came with an error for the id 10036 ( The server-side authentication level policy does not allow the user domain\user SID (X-X-X-XX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXX-XXXXX) from address xxx.xxx.xxx.xxx to activate DCOM server. Please raise the activation authentication level at least to RPC_C_AUTHN_LEVEL_PKT_INTEGRITY in client application ).


Can i know how to resolve this issue


Cyber Elite
Cyber Elite


A couple months back Microsoft pushed out an update that did some DCOM hardening that you are running into (KB5004442). I'm guessing you or your server team finally got around to patching your servers and enabled the registry key. My guess is that you are using an outdated version of PAN-OS or the User-ID agent, because I don't recall having to do anything about this particular patch and I can't find the advisory that was sent out about it. 



Thanks for your response. Can I know which version of PAN OS are affected?

L0 Member

We are experiencing the same problem.  Just installed Microsoft Patch Tuesday updates on our Domain Controllers.  Now getting the Windows Event ID 10036.  "The server-side authentication level policy does not allow the user DOMAIN\userid SID () from address <> to activate DCOM server.  Please raise the activation authentication level at least to RPC_C_AUTHN_LEVEL_PKT_INTEGRITY in client application."   Anyone else out there getting these errors or have a solution?  Our Paloalto PA-3050 is current on all updates, running version 9.1.11 of the software.

L4 Transporter

Hi All,


Yes, I have a client that has just patched their Windows 2016 servers and is now receiving the same error. Client is running PAN OS 9.1.11-h2 and User-ID agent 9.1.11-h2 on PA-3020 (latest available for this model device).


Tried the below Reg key to no avail:




And this to no avail:


Component services > computers > My computer > properties > set default properties > change default authentication level to 'packet integrity' rather than 'connect'


@BPry  @nikoolayy1 Any ideas here?

L0 Member

I am Having the problem also with two different pan-os 9.1.3 and 10.0.4

Ben I'm trying to do the same, and I followed the links down to the last detail, and I'm getting connection refused(0). Any ideas?

L4 Transporter

@echahine where are you seeing that error? can you provide a screen shot or log file?

First I'm seeing a connection refused on the GUI (image attached), and the error we're getting in the logs is connection failed, error code=0connection refused.JPG


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!