Superuser (read-only) (administer/view 'Everything') is unable to view reports

Reply
Highlighted
L2 Linker

Superuser (read-only) (administer/view 'Everything') is unable to view reports

Superuser with read-only rights are unable to view reports on Monitor tab --> PDF Reports. Any thoughts to why this is and how to fix it?

This installation is running 4.1.10.

Thank you.


Accepted Solutions
Highlighted
Palo Alto Networks Guru

Re: Superuser (read-only) (administer/view 'Everything') is unable to view reports

You can create a custom admin role that only allows custom report and everything else is either read-only or disabled. 

View solution in original post


All Replies
Highlighted
Palo Alto Networks Guru

Re: Superuser (read-only) (administer/view 'Everything') is unable to view reports

You can create a custom admin role that only allows custom report and everything else is either read-only or disabled. 

View solution in original post

Highlighted
L4 Transporter

Re: Superuser (read-only) (administer/view 'Everything') is unable to view reports

The following logs are output of debug related to the operation which read-only superuser is trying to view the report. (NOTE: this is in v5.0.3)

<request cmd="op" complete="/operations/download/report/predefined/scope/entry[@name='shared']/report-name/entry[@name='top-url-categories']/file-name" cookie="0890887635970713"/>

<response status="error"><msg><line>Not authorized for scope shared</line></msg></response>

It looks like you have no permission.

Because you can't select read-only rights in admin role editor for each report, I might able to guess two thoughts.

One is that this result is expected behavior and better result should be not showing report name as 'disable' rights does, another is a bug.

For workaround, I agree with jfitz-gerald, you should use admin role with 'enable' rights for reports.

Regards,

Highlighted
L2 Linker

Re: Superuser (read-only) (administer/view 'Everything') is unable to view reports

Palo Alto confirmed that this is a bug and that it will be with fixed in release 5.1. Until then, the workaround to create a custom admin role will work just fine.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!