user-id-agent-sequence is invalid.
cancel
Showing results for 
Search instead for 
Did you mean: 

user-id-agent-sequence is invalid.

Hi Team,

 

I'm seeing configuration invalid when I remove user-id agent from palo alto firewall and not able to commit.

 

PA-220 PANOS version 8.0.3.  Same model firewall I have removed I can able to commit.

 

Only in this firewall, I'm seeing this issue.

 

Screenshot (500).png

 

5 REPLIES 5

L7 Applicator

try performing a revert-to-running, then delete the user ID agent again

Tom Piens
Like my answer? check out my book! https://bit.ly/MasteringPAN

Hi @reaper

 

I have tried revert to running configuration option in the operation tab and then tried to delete the user-id agent sequence and commit but same error comming again.

 

 

Hi @reaper

 

I have taken running config xml file removed user-id agent and sequence configuration, change the file name uploaded and committed the changes it worked.

 

However thanks for your attention @reaper  and help.

 

Regards

Venky

Description:

We were observing error below when trying to delete user-id-agent and commit failed.

 

Error:

user-id-agent-sequence > user-id-agents 'Test1' is invalid. uknown or unsupported user-id-agent.

user-id-agent-sequence > user-id-agents is invalid

commit failed

 

Resolution:

 

show user-id-agent-sequence (To review the agents listed in sequence giving errors) 
set user-id-agent-sequence user-id-agents [ Test1 Test2 ]


show user-id-agent
set user-id-agent Test1 host-port port xxxx
set user-id-agent Test1 host-port collectorname test\test
set user-id-agent Test1 host-port secret T3$T
set user-id-agent Test1 host-port host x.x.x.x
set user-id-agent Test2 host-port port xxxx
set user-id-agent Test2 host-port collectorname test\test
set user-id-agent Test2 host-port secret T3$T
set user-id-agent Test2 host-port host x.x.x.x

 

Perform final steps;

delete user-id-agent-sequence
delete user-id-agent Test1
delete user-id-agent Test2

Regards,
Sufian Bhatti

L0 Member

This happened to me after I removed two user-id agents but didn't know there was another dependent setting. You need to edit the sequence that is at the bottom of the page near the 'add' button. Clicked, 'Custom Agent Sequence' and removed the old user-id agents I had in their before. Pushed the config and that resolved it.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!