Global Protect not working with MacOS Sonoma

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

Global Protect not working with MacOS Sonoma

L0 Member

Hello folks, 


i have a massive issue with GLobalProtect since the MacOS Sonoma Upgrade. It does not connect to the VPN Service. It tries to connect for a minute or so, but than it just says it can not. I don't even get to the part to insert a user or password. 



I checked to official website, and the client my company is using is 6.0.7-372, which should work with Sonoma. 

My IT support basically gave up, since im using a workaround (remote desktop windows -> remote desktop company) and the VPN account in general works. 


Any ideas? I can not find much clues to solve this for Sonoma. There are some for Ventura and before, but they all don't work. 





Cyber Elite
Cyber Elite

have you tried installing 6.2? I'm on 6.2.1 on sonoma and have no issues whatsoever

Tom Piens
PANgurus - Strata specialist; config reviews, policy optimization

Sadly the organisation only provides version 6.0.7. 

Cyber Elite
Cyber Elite

then your only recourse is to open a support ticket i think

Tom Piens
PANgurus - Strata specialist; config reviews, policy optimization

Cyber Elite
Cyber Elite

Hi @Raphael ,


You have a community account.  Do you have access to your company's support account?  If so, you can download the GP client.  I think the default NGFW configuration is not to force the client version when you connect.  You should be able to decline the downgrade if prompted unless your IT has configured it to force.





Help the community: Like helpful comments and mark solutions.

L0 Member

I have the same problem. GlobalProtect was working when I was still on Mac OS Big Sur. After upgrading to Mac OS Sonoma, it stopped working with the same error as described above (it also freezes for ~ 60 seconds before showing that error). Reinstalling GlobalProtect or reinstalling the system extensions/permissions did not solve the problem. 


This is GlobalProtect 5.08, my employer does not offer any older or newer versions to download. 

  • 5 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!