Incorrect GlobalProtect Version reported in GlobalProtect Monitor

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Incorrect GlobalProtect Version reported in GlobalProtect Monitor

L0 Member

When looking at the globalprotect logs within the monitor tab on my PA-3220 running 10.1.3 some clients are reporting the incorrect GP version. I have lots listed as running version 5.1.0. We currently don't have any workstations running that version.

I get the same if I run a custom report.

Any ideas why the incorrect version is being reported?

I don't have a globalprotect gateway license so not using HIP.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Cyber Elite
Cyber Elite

Maybe first remove globalprotect and all its files and then install again the new version as maybe some old files have remained as we had similar issue even after deleting and installing globalprotect as the normal delete did not remove all the files:

 

 

Uninstall the GlobalProtect App for Windows (paloaltonetworks.com)

 

GlobalProtect Error During Installation: An instance of GlobalProtect is already present on the syst...

View solution in original post

Maybe see active directory GPIO to change reg keys or other device management system like intune, jamf pro for MAC or maybe for the globalprotect to start  script.

 

 

Deploy Scripts Using the Windows Registry (paloaltonetworks.com)

View solution in original post

4 REPLIES 4

Cyber Elite
Cyber Elite

Maybe first remove globalprotect and all its files and then install again the new version as maybe some old files have remained as we had similar issue even after deleting and installing globalprotect as the normal delete did not remove all the files:

 

 

Uninstall the GlobalProtect App for Windows (paloaltonetworks.com)

 

GlobalProtect Error During Installation: An instance of GlobalProtect is already present on the syst...

L0 Member

I have since found a registry setting we were pushing out which was setting the version number. On removing the registry globalprotect would no longer connect. Repair of GP fixed the issue. Need to work out a plan to change this for all other workstations with out too much disruption.

Maybe see active directory GPIO to change reg keys or other device management system like intune, jamf pro for MAC or maybe for the globalprotect to start  script.

 

 

Deploy Scripts Using the Windows Registry (paloaltonetworks.com)

Cyber Elite
Cyber Elite

I forgot to add that I have used powershell scripts to play with the windows reg keys (no need to accept this comment as a solution):

 

How to Get, Edit, Create and Delete Registry Keys with PowerShell (netwrix.com)

 

 

Hope it help.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!