Community Blog

GlobalProtect: Notarization Requirements for macOS 10.14.5

by Community Manager a week ago - last edited a week ago (290 Views)

Read about the new requirements for macOS 10.14.5 that can have an impact on GlobalProtect. Check out "GlobalProtect: Notarization Requirements for macOS 10.14.5" to learn more about the requriements and the solutions to help. Got Questions? Get Answers on LIVEcommunity.

 

Starting with macOS 10.14.5, Apple requires that all new or updated kernel extensions be notarized.

 

Changes made by Apple in macOS 10.14.5 may have an impact if:

MacOS displays the following warning message at the time the Kernel Extension is loaded (if used):

System Extension Blocked
A program tried to load one or more system extensions that are
incompatible with this version of macOS. Please contact “Palo Alto
Networks” for support.

 

In addition, the GlobalProtect app displays the following error message:

Some components of the GlobalProtect app could not be launched due to
your operating system settings. This may cause some network traffic to
be blocked. Please contact your IT administrator for assistance.

 

Solution:

The GlobalProtect app for Mac endpoints currently uses kernel extensions for the Enforce GlobalProtect for Network Access and Optimized Split Tunneling for GlobalProtect features. If you are planning on using these features in your GlobalProtect deployment, use one of the options below to ensure they work as expected on endpoints running macOS 10.14.5.

  • If you upgrade your endpoint to macOS 10.14.5 and want to install the GlobalProtect app for the first time, you must install GlobalProtect app 5.0.2 and later releases or GlobalProtect app 4.1.12 and later releases.
  • If you uninstall an existing instance of the GlobalProtect app prior to upgrading your endpoint to macOS 10.14.5 and you want to reinstall the app following the upgrade, you must install GlobalProtect app 5.0.2 and later releases or GlobalProtect app 4.1.12 and later releases.
  • If you installed the GlobalProtect app prior to upgrading your endpoint to macOS 10.14.5, you can continue using previous versions of the app (5.0.1 and earlier releases or 4.1.11 and earlier releases) but later upgrades need to be to 4.1.12 or greater, or 5.0.2 or greater.

 

NOTE: You can find the Apple announcement here: New Notarization Requirements

Ask Questions Get Answers Join the Live Community
Labels