Reply
L1 Bithead
Posts: 4
Registered: ‎08-29-2017
Accepted Solution

Best Practices Analysis Not Running

I'm trying to run a BPA for one of my Panorama-managed devices. I got everything imported into the project, but the BPA never runs. The progress bar advances to "Done!" with no visible errors on the front-end, but Last Run stays at Never Analyzed. Checking the Apache error logs, it appears thta there's a missing executable (bpa-cli). Is this something we have to get separately?

L7 Applicator
Posts: 908
Registered: ‎03-22-2011

Re: Best Practices Analysis Not Running

Hi, we found an issue in new installations where the bpa was not properly updated, Please update your Expedition to 1.0.85.1 and try it again. Thanks

L1 Bithead
Posts: 4
Registered: ‎08-29-2017

Re: Best Practices Analysis Not Running

Upgraded to 1.0.85.3 and the BPA is working now - thanks!. APT was/is complaining about the repo though.

 

Reading package lists... Done
E: The repository 'https://conversionupdates.paloaltonetworks.com expedition-updates/ Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I was able to work around it by disabling the checks but that's not ideal.

 

sudo apt -o Acquire::AllowInsecureRepositories=true \
> -o Acquire::AllowDowngradeToInsecureRepositories=true \
> update

 

L7 Applicator
Posts: 908
Registered: ‎03-22-2011

Re: Best Practices Analysis Not Running

We have to build a new repository with a stronger certificate, its a matter of time, its coming. Thanks

L0 Member
Posts: 1
Registered: ‎12-20-2017

Re: Best Practices Analysis Not Running

Thanks for this ! This solutions worked like charm. Looking forward to those new repos !

L1 Bithead
Posts: 9
Registered: ‎04-19-2012

Re: Best Practices Analysis Not Running

Hi,

Im having this issue with a specific config file, with others is working OK.

Looking at error.log in apache a get this:

 

Traceback (most recent call last):

  File "/usr/local/bin/bpa-cli", line 11, in <module>

    sys.exit(main())

  File "/usr/local/lib/python3.5/dist-packages/best_practice_assessment_ngfw_pano/json/generate.py", line 274, in main

    xml_config = XMLConfig.read_xml(args.xml)

  File "/usr/local/lib/python3.5/dist-packages/best_practice_assessment_ngfw_pano/parser/xml_config.py", line 171, in read_xml

    return cls(tree, **kwargs)

  File "/usr/local/lib/python3.5/dist-packages/best_practice_assessment_ngfw_pano/parser/xml_config.py", line 26, in __init__

    self.version = float(next(iter(query.get_version(self.tree)), '0.0')[:3])

  File "src/lxml/xpath.pxi", line 432, in lxml.etree.XPath.__call__

  File "src/lxml/apihelpers.pxi", line 43, in lxml.etree._documentOrRaise

ValueError: Input object has no document: lxml.etree._ElementTree

 

Thanks for any help

L7 Applicator
Posts: 908
Registered: ‎03-22-2011

Re: Best Practices Analysis Not Running

Have you tried to upgrade to 1.0.88 and try it again?

L1 Bithead
Posts: 9
Registered: ‎04-19-2012

Re: Best Practices Analysis Not Running

Hi, 

 

I just upgraded to 1.0.88, but I'm still getting no results with this specific config.

 

Thanks for your help.

L7 Applicator
Posts: 908
Registered: ‎03-22-2011

Re: Best Practices Analysis Not Running

Just for verifying, the VM you have was downloaded from here at live or you got the copy from another source? If was a different source please download and try the version its hosted here at live.

L1 Bithead
Posts: 9
Registered: ‎04-19-2012

Re: Best Practices Analysis Not Running

I downloaded the VM from live. 

As I told you for other configurations I have tried it works ok, but there is a specific one that doesn't give results.

 

Thanks for your help,

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!