REST API parameter error for non vsys device

Announcements

Changes to the LIVEcommunity experience are coming soon... Here's what you need to know.

Reply
SeanFarber
L0 Member

REST API parameter error for non vsys device

I'm having an issue with v9.1 that I was not having with v9.0.  On a vm-series firewall with no vsys I am getting the following error.

 

<Response [400]> b'{"code":3,"message":"Invalid Query Parameter: location=shared","details":[{"@type":"CauseInfo","causes":[{"code":8,"module":"panui_restapi","description":"Invalid Query Parameter: location=shared"}]}]}'

 

Location is a required parameter and the default is shared if no vsys.   Has anyone else experienced a similar issue?

Tags (2)
Jimmy_Taylor
L1 Bithead

Think I found the solution.

 

Reading this comment, it looks like a non-vsys system is still considered a vsys system.

 

So in your REST API query params, set the following keys:

 

  • location: vsys
  • vsys: vsys1

 

That should do it. It worked for me, at least. 

Tags (4)
SeanFarber
L0 Member

I tried that too but unfortunately it didn't work for me.  I wonder if it being a vm-series has anything to do with it.

Jimmy_Taylor
L1 Bithead

Are your parameters all populated? 

 

Here's a quick snapshot from Postman:

 

Jimmy_Taylor_0-1617379626857.png

Edit: And here's the URI path I used to test:
/restapi/9.0/Policies/SecurityRules?location=vsys&vsys=vsys1

Jimmy_Taylor
L1 Bithead
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!