QRadar integration error: Failed to execute qradar-searches command (EDITED).

Showing results for 
Show  only  | Search instead for 
Did you mean: 

QRadar integration error: Failed to execute qradar-searches command (EDITED).

L0 Member

Hi all, I have a problem with QRadar integration. Let me summarize my environment and basic configuration.

Cortex XSoar version: 6.10.0
QRadar integration version: IBM QRadar v3
QRadar - Generic Incoming Mapper
Incident type: 
Qradar Generic
Event an fields to return from the events query: QIDNAME(qid), LOGSOURCENAME(logsourceid), CATEGORYNAME(highlevelcategory), CATEGORYNAME(category), PROTOCOLNAME(protocolid), sourceip, sourceport, destinationip, destinationport, QIDDESCRIPTION(qid), username, PROTOCOLNAME(protocolid), RULENAME("creEventList"), sourcegeographiclocation, sourceMAC, sourcev6, destinationgeographiclocation, destinationv6, LOGSOURCETYPENAME(devicetype), credibility, severity, magnitude, eventcount, eventDirection, postNatDestinationIP, postNatDestinationPort, postNatSourceIP, postNatSourcePort, preNatDestinationPort, preNatSourceIP, preNatSourcePort, UTF8(payload), starttime, devicetime (Note: it is the default one).


The connection with QRadar istance works fine and I'm able to fetch offenses.
When an incident is pulled, for every incident, the associated PlayBook ends with following error:

Playbook QRadar Generic execution error


Failed to execute qradar-searches command. Error: Could not create search for offense_id:

Now, I attached other QRadar istances to our cortex XSoar and never got this error. So, there is a difference between this specific istances and the current one? Yes, we have some custom fields created for reports and Offense ID is one of them.
So, my assumptions/doubts are:

  • My analysis is correct' Is the custom field that create the error?
  • If the above point is correct, I don't understand why. is it telling me that he's not able to retrieve events correlated to the offense id? 
Edit to add: I performed further test and I think the custom field is not the root cause. First, it is not used in our search; second, I tried a simpler search in the Playground like the following:

!qradar-searches query_expression="select QIDNAME(qid)"

And I still get the same error. I don't think it's a permission related problem (the user that connect and pull has right privileges) and on QRadar the complete rule work fine.



L2 Linker

since you are working with Qradar V3 and need to retrive events try the below search, feel free to change the event ID. 


!qradar-search-retrieve-events query_expression="SELECT * from events where \"EventID\"='4624' limit 2


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!