Custom miner, 'Commit Failed: unknown node class', no nodes.json file

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

Custom miner, 'Commit Failed: unknown node class', no nodes.json file

L1 Bithead

Hi All,


I followed the same steps as in the ytexample guide.


Including putting my class in:



By the way, this directory doesnt exist:



Im getting 'Commit Failed: unknown node class' when I try to commit the node which references the prototype created from the above article.


There was no /opt/minemeld/engine/current/nodes.json file. Indeed, I searched all of the Ubuntu VM hosting Minemeld and couldnt find a nodes.json anywhere.


Ive tried  copying this nodes.json and adding my node to the bottom and putting in /opt/minemeld/engine/current/  along with my class: 


Which is as per this message from a couple years ago:


However, I still get the same error. 


Does anybody have any ideas?


Appreciate your help.







L1 Bithead

Hi @Lmori

I can see you have helped a few people out with the same issue. Ive followed your steps (as much as possible) and still have the same issue. Are you able to offer any insight?


From the below, you can see I tried to follow what worked for somebody else here:

Not sure if its relevant, but Im running Minemeld on ubuntu 16.04 LTS.

This is my /opt/minemeld/engine/current directory:
luke@ubuntu16:/opt/minemeld/engine/current$ ll
total 48
drwxr-xr-x 7 minemeld minemeld 4096 Apr 16 17:32 ./
drwxr-xr-x 3 minemeld minemeld 4096 Apr 10 11:14 ../
drwxr-xr-x 2 minemeld minemeld 4096 Apr 10 11:14 bin/
drwxr-xr-x 3 minemeld minemeld 4096 Apr 10 11:14 include/
drwxr-xr-x 3 minemeld minemeld 4096 Apr 10 11:14 lib/
-rw-r--r-- 1 minemeld minemeld 1254 Apr 10 11:14 LICENSE.rst
drwxr-xr-x 2 minemeld minemeld 4096 Apr 10 11:14 local/
-rw-r--r-- 1 root     root     4781 Apr 16 17:32 nodes.json
-rw-r--r-- 1 minemeld minemeld  789 Apr 10 11:14 README.rst
drwxr-xr-x 3 minemeld minemeld 4096 Apr 10 11:14 share/
-rw-r--r-- 1 root     root     2154 Apr 16 15:50

nodes.json (which didnt exist in /opt/minemeld/engine/current and so I had to import a copy from github)
 in the above directory includes this:

"minemeld.ft.ytexample.YTExample": {
        "class": "minemeld.ft.ytexample:YTExample"

I then tried to run "sudo -u minemeld /opt/minemeld/engine/current/bin/pip install -e /opt/minemeled/engine/core/"
which produced this error, even with -H on sudo:

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at
WARNING: The directory '/home/luke/.cache/pip' or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
ERROR: /opt/minemeled/engine/core/ is not a valid editable requirement. It should either be a path to a local project or a VCS URL (beginning with svn+, git+, hg+, or bzr+).

I have also put a copy of in what looks like the default directory for packages:
luke@ubuntu16:/opt/minemeld/engine/current/lib/python2.7/site-packages/minemeld/ft$ ll | grep
-rw-r--r--  1 minemeld minemeld  4704 Apr 10 11:14
-rw-r--r--  1 minemeld minemeld  4886 Apr 10 11:14 google.pyc
-rw-r--r--  1 minemeld minemeld 17277 Apr 10 11:14
-rw-r--r--  1 minemeld minemeld 15122 Apr 10 11:14 table.pyc
-rw-rw-rw-  1 root     root      2154 Apr 16 11:28


I very much appreciate any help you can give.





  • 1 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!