Downgrade Pan OS

Reply
Highlighted
L4 Transporter

Downgrade Pan OS

Does the debug svm revert still work on the 8 os? 

 

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClcYCAS

Highlighted
Cyber Elite

@jdprovine,

It's debug swm revert; technically this is really just activating the other partition on the system, so while its most commonly used to downgrade PAN-OS it isn't specific to downgrading the software. However, to answer your question this still works perfectly fine and likely isn't a command that will change. 

Highlighted
Community Team Member

@jdprovine,

 

Yup it's still there in PAN-OS 8.1.x as BPry already mentioned :

 

admin@PA-lab> show system info

...

sw-version: 8.1.2

...

 

admin@PA-lab> debug swm revert               [revert back to last successfully installed software]

 

Cheers !

-Kiwi.

 
Highlighted
L4 Transporter

@kiwi @BPry

 

Okay cause when I tried it on my test PA with 8 on it, it gives me an invalid syntax error

Highlighted
L7 Applicator

To add to @BPry and @kiwi

 

you will want to check what revertable option is available to you (> debug swm status): you can revert to the last version that was 'installed' on the secondary partition

if you followed a linear upgrade path and did not install the next version yet, you will be able to revert to the previous version

if you already installed the _next_ version in line, you will not technicvally be able to 'revert' as the revert action would actually move you forward

 

ie. before installing 8.1.5:

 

admin@PA-200> debug swm status

Partition         State             Version
--------------------------------------------------------------------------------
sysroot0          RUNNING-ACTIVE    8.1.2
sysroot1          REVERTABLE        8.1.1
maint             EMPTY             None

after installing but before rebooting:

 

admin@PA-200> debug swm status

Partition         State             Version
--------------------------------------------------------------------------------
sysroot0          RUNNING-ACTIVE    8.1.2
sysroot1          PENDING-REVERT    8.1.5
maint             EMPTY             None
Tom Piens - PANgurus.com
Find my book at amazon.com/dp/1789956374
Highlighted
L4 Transporter

@reaper @kiwi @BPry

 

go figure now its working LOL

 

debug svm status

 

Partition State Version
--------------------------------------------------------------------------------
sysroot0 RUNNING-ACTIVE 8.1.5
sysroot1 REVERTABLE 8.1.4
maint EMPTY None

 

jprovine@PA220-test-mgt> debug swm revert

Reverting from 8.1.5 (sysroot0) to 8.1.4 (sysroot1)

Highlighted
L4 Transporter

@reaper @kiwi @BPry -

 

 oops its a typo svm instead of swm

 

 

jprovine@PA220-test-mgt> debug svm status

Invalid syntax.
jprovine@PA220-test-mgt> debug svm status

Highlighted
L7 Applicator

Did you let auto commit complete?
It may take a moment for swm to become available
Tom Piens - PANgurus.com
Find my book at amazon.com/dp/1789956374
Highlighted
L4 Transporter

@reaper

It was a typo on my part  I entered svm instead of swm LOL ;)

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!