Global protect DNS name resolution.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Global protect DNS name resolution.

Not applicable

Hello Experts,

Through global protect, users are getting IP address from the pool and take network setting as defined including primary DNS and Secondary DNS.

but the users want to access servers via name(s) not IP addess(es). Since it was working before with cisco remote vpn.

Please let me know is there any setting in global protect gateway to make it functional?

Thank you.




L4 Transporter

Hello Parvez

In my opinion it isn't GP issue. Please use in GP configuration your local DNS servers, servers that are able to resolve name of servers that are want to use by your users.

Maybe you miss security policy that allow DNS traffic from zone VPN to zone where are Your DNS sererwers?



Hello Slawek,

GP tunnel interface is the part of inside zone and DNS servers resides in the same zone.



Could You ping by IP address this servers?

What about nslookup - is it possible to get response about

L4 Transporter

Firewall Policy? is DNS allowed from the tunnel zone to the destination zone ?

yes you need to autorize via security policy dns app or via service base on tcp and udp 53 port

since tunnel interface is the part of inside zone - from inside to outside permit all for this VPN subnet.

Moreover, after connecting GP, we tried nslookup of some servers it is resolving the correct IP address.

I tried to access(through RDP) servers via its name it is not working but via IP address - It is working.

I'm 99,99% sure, if everything is allowed from VPN to the LAN and nslookup works, it shouldn't be a firewall issue!

It can be the HOST.txt file, Windows/3rdParty Client Firewall, DNS Server, NIC driver/setting or the Remote Server itself...

You have to google that. Sorry, because I don't know your infrastructure.

BTW: Do you see something in the traffic logs?

I tried to access(through RDP) servers via its name it is not working but via IP address - It is working

and when you try a nslookup with this server name, what is the result?

if it's work it's not a firewall issue. but RDP service on this server

L3 Networker

This is actually a well known problem for Windows as well as Mac OSX.  It has to do with the DNS server binding order.

Written for XP but applies to 7 as well:

Cannot Change the Binding Order for Remote Access Connections

Google search that shows how wide spread this issue is and some resolutions for it.

L0 Member

Were you ever able to find a solution to your problem? I'm experiencing the same thing running macOS 10.15.3. Upon initial connection with GlobalProtect I open terminal and run "scutil --dns". My nameservers show the IPs of the my internal corporate network. After a few seconds I can run the same command, and the nameservers has changed to localhost "".

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!