GlobalProtect not connecting on Mac

Showing results for 
Search instead for 
Did you mean: 

GlobalProtect not connecting on Mac

L1 Bithead

I'm trying to use GlobalProtect on a Mac, but it won't connect. I don't know much about Mac in general which definitely won't help me, I'm doing this for someone else and this is my first time using GlobalProtect on one. When I start the app and type the username, password and portal it just says connecting in the status tab. So far I've tried reinstalling the app, restarting the Mac, changing networks, double checking username/password/portal.


Is this on MacOS 10.13 High Sierra?


Go to settings

Security & privacy

General tab

Click Allow on "System software from developer Palo Alto Networks has been blocked..."

Cyber Elite
Cyber Elite


Look at the logs and see if it tells you anything. In addition I would make sure that the firewall is actually recieving traffic when you attempt to connect, that would at least verify that macOS isn't reseting the connection before it even leaves the Mac. 

@Christian_SvendsenThe Mac is running macOS Sierra 10.12.6. There is no option to allow it.

@BPryI've looked at some of the log files, but they don't really tell me anything.



P1069-T775   Oct 30 11:47:45:105435 Info ( 581): Received wake notification

P1069-T775   Oct 30 11:55:58:271529 Info ( 288): receive sig 15

P1069-T775   Oct 30 11:55:58:271560 Info ( 233): Stop PanGPS

P1069-T10511 Oct 30 11:55:58:924416 Info ( 662): debug thread ends

P1069-T775   Oct 30 11:55:59:16244 Info ( 468): Main thread run loop stopped.

P1069-T775   Oct 30 11:55:59:16509 Info ( 474): killServiceEvent is signaled

P1069-T775   Oct 30 11:55:59:16705 Debug( 483): g_isDaemon: 0, g_isPrelogonEnabled: 0, s_quitFromSwithOut: 0, g_needToRestart: 0

P1069-T775   Oct 30 11:55:59:16725 Info ( 495): PanGPS stops

P  90-T775   Oct 30 11:56:49:99550 Debug( 330): PanGPS, working directory is /Library/Logs/PaloAltoNetworks/GlobalProtect/

P  90-T775   Oct 30 11:56:49:150052 Info ( 142): ####################### Start PanGPS service (ver: 2.3.0-28) #######################

P  90-T775   Oct 30 11:56:49:150077 Info ( 143): Debug level is 5

P  90-T775   Oct 30 11:56:49:150095 Info ( 144): User is (null), home is (null), login is root

P  90-T775   Oct 30 11:56:49:150101 Debug( 146): IsDaemon is 1

P  90-T775   Oct 30 11:56:49:325472 Info (  70): Shared global defaults: <NSUserDefaults: 0x100701690>


P  90-T775   Oct 30 11:56:49:535759 Info ( 191): Couldn't obtain debug level from settings

P  90-T775   Oct 30 11:56:49:535948 Info ( 197): PrelogonEnabled is 0

P  90-T775   Oct 30 11:56:49:535960 Info ( 199): Daemon process needs to quit since prelogin is disabled

P  90-T775   Oct 30 11:56:49:535966 Info ( 461): StartPanAgent() failed

P 353-T775   Oct 30 11:56:55:336118 Debug( 330): PanGPS, working directory is /Library/Logs/PaloAltoNetworks/GlobalProtect/

P 353-T775   Oct 30 11:56:55:336251 Info ( 142): ####################### Start PanGPS service (ver: 2.3.0-28) #######################

P 353-T775   Oct 30 11:56:55:336261 Info ( 143): Debug level is 5

P 353-T775   Oct 30 11:56:55:336273 Info ( 144): User is USER, home is /Users/USER, login is USER

P 353-T775   Oct 30 11:56:55:336279 Debug( 146): IsDaemon is 0

P 353-T775   Oct 30 11:56:55:368256 Debug( 178): setreuid to 501

P 353-T775   Oct 30 11:56:55:368607 Info (  57): Shared user defaults: USER, <NSUserDefaults: 0x1011054f0>


P 353-T775   Oct 30 11:56:55:370653 Info (  70): Shared global defaults: <NSUserDefaults: 0x101105670>


P 353-T775   Oct 30 11:56:55:380766 Info ( 549): User Switch Monitor init finished

P 353-T775   Oct 30 11:56:55:380784 Info ( 189): Set debug level to 5

P 353-T775   Oct 30 11:56:55:381203 Info ( 197): PrelogonEnabled is 0

P 353-T775   Oct 30 11:56:55:381254 Info ( 499): cannot open /var/run/, assume no old instance running

P 353-T9999  Oct 30 11:56:55:381310 Info ( 656): debug thread starts

P 353-T775   Oct 30 11:56:55:382236 Info (  34): Mac OS X 10.12.6

/Applications/ failed to load - (libkern/kext) not loadable (reason unspecified); check the system/kernel logs for errors or try kextutil(8).

P 353-T775   Oct 30 11:56:56:630250 Debug(  59): driver installed

P 353-T775   Oct 30 11:56:56:630315 Error(  66): Cannot initialize driver: 1

P 353-T775   Oct 30 11:56:56:630334 Info ( 466): Start main thread run loop.


10/30/2017 11:56:56.103664[Debug  298]: ioctl return 2

10/30/2017 11:56:56.106636[Debug  298]: ioctl return 2

10/30/2017 11:56:56.106705[Debug  298]: ioctl return 2

10/30/2017 11:56:56.107934[Info    40]: Darwin version 16.7.0


10/30/2017 11:56:56.630025[Info    60]: Install pangpd_10.9.kext finished with result 0

10/30/2017 11:56:56.630095[Debug  298]: ioctl return 2

10/30/2017 11:56:56.630279[Debug  298]: ioctl return 2


@K.ArneIt looks like a lot of the PanGPS stuff is failing. Your logs indicate that the .pid and the kext file can't be opened. 


I would remove GlobalProtect all together and then make sure that you actually delete all of the files related to GP. The uninstaller doesn't remove all of the directories and that could be screwing up your install, because something isn't loaded right or given the correct permissions. 

@BPryI deleted all the files I could find and removed GP. After installing it I got the exact same problem. Just to be sure, is there a specific install directory to GP or is it just in the Applications folder?


So just at a cursory glance, a machine that I haven't had GP installed for a while still had files located at /Users/$USER/Collect and then /Library/Application Support/PaloAltoNetworks. Note that I had multiple different Collect$ folders due to having different installes of GP present at one time or another. 

@BPryThis mac doesn't have /Users/$USER/Collect as a directory at all. The other one I already tried deleting without success.


Just to verify you did actually replace $USER with your username correct? This could actually be a Traps directory, so you may trully not have it. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!