GlobalProtect not using AD group

Showing results for 
Search instead for 
Did you mean: 

GlobalProtect not using AD group

L2 Linker



I am running a PA-VM on AWS. It has two interfaces, one for management, one for data.

I have created an LDAP connection to our network and can log into GP using my AD credentials. So far, so good.


I need to have separation of users and assigned IPs based on group membership. I have an authentication profile with two sequences. One to match on the group that my account is a member of, the second uses local authentication.


In the GP gateway, I have the authentication set to the auth sequence (which uses the first authentication profile - the one that should match my account and group set first), and in the agent client settings, I have two entries. the first one should give me an IP address from the first range, the second entry is set to any/any and gives an IP from a different range.


When I connect, I use my username/password from AD but get an IP address from the second range.


The logs show these entries (note I have replaced the actual AD details):


1,2017/09/12 05:48:17,4E0FEDAE31E65C2,31,0x0,USERID,login,53,2017/09/12 05:48:17,0,0,0,0,,PA-VM,1,vsys1,,xx\sfordham,,0,1,2592000,0,0,vpn-client,globalprotect,0,0,,2017/09/12 05:48:18,1


admin@PA-VM> show user group-mapping state all

Group Mapping(vsys1, type: active-directory): SaaS-Users
Bind DN : CN=xxx,OU=xxx xxx - Shared,DC=XX,DC=xxx
Base : DC=XX,DC=xxx
Group Filter: (None)
User Filter: (None)
Servers : configured 1 servers
Last Action Time: 1607 secs ago(took 0 secs)
Next Action Time: In 1993 secs
Number of Groups: 1
cn=replaced_xxx,ou=security groups with mailbox,ou=security groups - shared,dc=xx,dc=xxx



admin@PA-VM> show user ip-user-mapping all

IP Vsys From User IdleTimeout(s) MaxTimeout(s)
--------------- ------ ------- -------------------------------- -------------- ------------- vsys1 GP xx\sfordham 2591689 2591689
Total: 1 users



From what I have read, GP in the above command *should* be AD


admin@PA-VM> show user user-ids

User Name Vsys Groups
------------------------------------------------------------------\sfordham vsys1 cn=replaced_xxx,ou=security groups with mailbox,ou=security groups - shared,dc=xx,dc=xxx
Total: 22


So it looks like it is reading all of the necessary details - I can log in using my AD account, for example - it's just the mapping that's incorrect.


Can anyone advise? 


Apologies if I have missed something blindingly obvious. I only started working with PA last week, so am learning as I go!


I added the domain (without the .local) to the Test2 auth profile and commited the change, but still get that I am not allowed with the authentication profile Test2.


BTW, thanks for all the help, I really appreciate it!

ok are you a wiresharky person...


if so then i would go to monitor/packet capture


manage filter id 1 destination (ldap server ip)

filter id 2 source (same ladap server ip)


ok that box.


add a capture stage for firewall, recieve and transmit.


start capture and as soon as started try cli auth vis test2 profile with group added (as previous)


as soon as failed, refresh captured files window and click on file to open with wireshark.


although a bit confusing, ladap is sent in cleartext so should see whats going on.


BTW, no problem.

if we could arrange a session i would gladly take a look via gotomeeting or teamworks. not sure how to comm ouside this


Also...   going back to the xx domain name... you could also add this to the user domain in group-id settings and give that a go before wireshark

Well.. this is weird...


I tried the wireshark capture, and could see all of the HTTPS traffic to the same server as the LDAP box, but this is because I am using the PA GUI from this NAT'd address, but I could not see any LDAP traffic in either the transmit or receive logs.


I cleared the user mapping (clear user-cache all) and tried again - still no LDAP info in the pcaps.


Using the client vpn, I did actually get the correct IP address - but the authentication command still fails...



firstly.. to confirm ... what is your group-id domain user set to.


secondly.. under device/setup/services/service route configuration, is ldap set to use default. if so the will not show in capture as you need to set ldap to the trusted interface ethernet x/x (whatever can reach the ldap servers.

also add destination port 389 to destination ldap server and source port 389 to source ldap server in capture filter to scrub https etc...

The service route is set to use the default (management) - however I cannot assign this to the e1/1 interface:


Screen Shot 2017-09-14 at 10.19.52.png


All I have here is default or any - possibly as it's in AWS using DHCP??



Stuart, Hi.


ok perhaps wireshark on server may be another option but do you need to know whats going on as you mentioned the IP allocation is now working as expected.

I was going to ask why you need to allocate subnet ranges for users, i assume its for admin purposes. we have been down this route but found it healthier all round to use AD groups in security policy.


I could of course be missing something more obvious here as to your purpose.

Morning 🙂


The plan is that we have a centralized VPN solution (currently we have two solutions one for access to one part of our network, and another - for a smaller subset of users to another section of our network).


The plan is that we have a unified solution, and depending on user group, we can permit/deny traffic between the network sections - hence the desire to hand out different IP ranges based on group membership.


I will see if I can run wireshark on the ldap server and that may shed some light on it.


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!