Home Lab Setup - PA VM + Windows 10 (Vmware)

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Home Lab Setup - PA VM + Windows 10 (Vmware)

L2 Linker

Hi guys, I have a beginner's question I'd like to ask.


I want to set up my own home lab on VMware workstation 16 and something doesn't add up.


First, my simple network topology is the following:

  • My home network is on a 192.168.1.X network (default gateway .
  • I have a PA-VM 10.1 with a management ip of (default gateway with 2 interfaces configured: eth1/1 for the Outside zone with IP and an Inside Zone on eth1/2 with IP
  • I also set up a Windows 10 machine in Workstation for testing purpouses, I set the static IP to , netmask , default gateway is the eth1/2 (i.e , DNS is
  • I configured a NAT policy from the inside zone to the outside zone and also configured a default route for the default VR.
  • Also configured a security policy from Inside to Outside and Outside to Inside in order to access the internet
  • Configured Mgmt profiles to enable ping for both interfaces.

Background information: I saw somewhere that I should go to Virtual Network Editor and add a Vmnet with DHCP disabled with a IP so it could be assigned to an additional interface for the PA VM and for the Windows 10 Network Driver.

So I created a VMnet3 with DHCP off and IP and assigned it to the third Network Adapter (eth1/2) for PA VM and also for the Network Adapter of the Windows 10 machine.


All the above were completed, and still, I can't ping anything from my Windows 10 machine (not the interface, nor the internet). The Windows 10 machine is not visible on any traffic logs, and I'm pretty sure it's not reaching the network for some reason. I'm sure I'm missing something still, I just don't know what exactly.



1 accepted solution

Accepted Solutions

Hi Samy,

It was a fairly silly mistake. You should just set up the default gateway of the server the same as the interface ( in my case).

As mentioned before, it was a rookie mistake from my side.

View solution in original post


L5 Sessionator

If you want to save yourself a lot of time and know without a doubt the Palo config is good to go, use our XML-API based solution builder, IronSkillet. 


Instructions on pulling the container to Docker are here.


Then you are able to import a skillet using the following link here (use the github repo)


After that, in two clicks you'll have rules and topologies built to best practice. This will further confirm that you may require more troubleshooting within VMWare. 

Help the community! Add tags and mark solutions please.

L1 Bithead

Hello ,

I have the same issue .

Did you find any answer on this ?

L1 Bithead

Hi ,

I have solved this problem , i think you have configured the wrong subnetmask on the respective interface , I assumed you have configured /32 for the ip address but you need to change it to /24 if your network belong to /24

Hi Samy,

It was a fairly silly mistake. You should just set up the default gateway of the server the same as the interface ( in my case).

As mentioned before, it was a rookie mistake from my side.

Hi sir i have problem when set up lab PA-VM in vmware pro 16 windows 11, i'm success booting until login via cli or gui but a few momment PanOS stopping own and this repeating? any suggest sir?because you also setup lab same in vmware pro, please help me solved this problem



  • 1 accepted solution
  • 5 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!