Issue with config backup

Reply
Highlighted
L4 Transporter

Issue with config backup

PANOS 8.1.9

 

When we are doing the config backup we do not see all the config is getting backed up – for example, the firewall rules, NAT and port forwarding rules are not seen in the backup – Apparently a very fraction of the configuration is saved.

 

Can you please suggest how to fix this?


Accepted Solutions
Highlighted
Community Team Member

Hi @FarzanaMustafa 

 

Is your device managed by Panorama ?

 

HOW TO EXPORT BACKUPS OF MANAGED DEVICE CONFIGURATION FILES FROM PANORAMA 

 

Hope it helps,

-Kiwi

View solution in original post

Highlighted
Cyber Elite

@FarzanaMustafa ,

You would simply need to decompress the folder and import the dc2-firewall-01_002501002685.xml file onto the firewall ('Import named configuration snapshot' in the GUI) and then load ('Load named configuration snapshot') and commit the configuration. 

View solution in original post


All Replies
Highlighted
Community Team Member

Hi @FarzanaMustafa 

 

Is your device managed by Panorama ?

 

HOW TO EXPORT BACKUPS OF MANAGED DEVICE CONFIGURATION FILES FROM PANORAMA 

 

Hope it helps,

-Kiwi

View solution in original post

Highlighted
L4 Transporter

How are you doing the backup?

Highlighted
L4 Transporter

@RobinClayton @kiwi 

Editing my response.

 

The device is managed by Panaroma.
I have tried via Panorama as per the link (thank you!) and this one exports the config as following

panorama.png



and the Panorama_000702870043.xml apparently has all the config- including both the firewalls.

What do we do when we need to restore a config for one firewall? example dc2 firewall.
Say, dc2 firewall died and we received a blank replacement – in that case we need to restore dc2 config only.

How is this to be done?

Highlighted
Cyber Elite

@FarzanaMustafa ,

You would simply need to decompress the folder and import the dc2-firewall-01_002501002685.xml file onto the firewall ('Import named configuration snapshot' in the GUI) and then load ('Load named configuration snapshot') and commit the configuration. 

View solution in original post

Highlighted
L4 Transporter

What/Why do you think there is anything missing?

 

As BPry says, just load the XML to the firewall. Ensure the new F/W is on the same SW version first to ensure compatibility.

 

If you have not got a spare or anything you can test a re-load, the download and install "Pan Expedition" for free and load the config into that.

 

Rob

Highlighted
L4 Transporter

Sorry, just clicked Resolved too soon.

 

If we only import dc2-firewall-01_002501002685.xml, this file does not have all the config.

The file “Panorama_000702870043.xml” has most of the config ( which also includes dc1’s config)


so if we need to restore dc2 firewall config – under this scenario – what is the full config restoration procedure for dc2 only?

Highlighted
L4 Transporter

What's Missing???

 

Also Try a manual backup export from DC2


Rob

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!