Problem Access Routes with VPN

Reply
Highlighted
Not applicable

Problem Access Routes with VPN

Hi everybody.

I've got a problem with my configuration of VPN for remote clients,If I configure only one access route (see picture1), I obtain the following routing table and everything works well:

As VPN client we are using vpnc from a Linux distribution (the same problem happens with cisco VPN client from windows computers)

If I configure only one access route (see picture1), I obtain the following routing table and everything works well:

Kernel IP routing table

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface

193.144.152.5   192.168.1.1     255.255.255.255 UGH    1500 0          0 wlan0

1.1.1.1         0.0.0.0         255.255.255.255 UH        0 0          0 tun0

192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0

10.0.0.0        0.0.0.0         255.0.0.0       U         0 0          0 tun0

0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 wlan0

If I configure more than one access route (see picture2), I don't obtain the correct routes and I lose the default gateway route:

Kernel IP routing table

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface

193.144.152.5   192.168.1.1     255.255.255.255 UGH    1500 0          0 wlan0

1.1.1.3         0.0.0.0         255.255.255.255 UH        0 0          0 tun0

192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0

0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 tun0

Please, can you help me? Anyone with similar problem?


Accepted Solutions
Highlighted
Not applicable

Hi.

Finally I've created a shell script using vpnc command to connect and add the routes. It works.

In my opinion, PaloAlto should offer a solution for GlobalProtect VPN on Linux platforms, in case they want to take advantage over their competitors.

Bye!

View solution in original post


All Replies
Highlighted
Not applicable

Sorry, one correction:

Picture1: more than one subnets in Access Route configuration

Picture2: only one subnet in Access Route configuration

I've figured out that the problem can be related to a try of summarize subnets of the vpnc client, but I'm not sure. Could you help me please?

Thank you.

Highlighted
Not applicable

Anyone with the same problem? Could you help me please?

Highlighted
Not applicable

Hi.

Finally I've created a shell script using vpnc command to connect and add the routes. It works.

In my opinion, PaloAlto should offer a solution for GlobalProtect VPN on Linux platforms, in case they want to take advantage over their competitors.

Bye!

View solution in original post

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!