Python interpreter error Ansible

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

Python interpreter error Ansible

L0 Member

 

 

 

 

2 REPLIES 2

Cyber Elite
Cyber Elite

@pilgrimblues,

The error that is most important here from a really brief glance is the one that points out that you're missing pan-python. You need to install that so things can actually function. 

Cyber Elite
Cyber Elite

@pilgrimblues,

Then the interpreter that Ansible is using and the one that you did the pip install on are not the same. You can find the interpreter path by doing the following:

import sys
print(sys.executable)

Part of the initial setup of Ansible should have been setting the interpreter to what you wanted. I'd recommend walking through an Ansible tutorial to get it up and running before you start following what PAN has, as PAN assumes that you have a functional environment fully setup first. 

 

You could also just do the install through ansible.builtin.pip to run the install through the interpreter that Ansible is already using.

  • 478 Views
  • 2 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!