user-id not mapping

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

user-id not mapping

L0 Member

Hello community,

I'm facing an issue with user-id agentless.

i did the following configurations 

  1.  Create LDAP Server Profile
  2. LDAP/Group Mappings configured on FW
  3. User-ID Group Mapping Settings.
  4. server monotoring is connected
  5. Include network set
  6. User ID on the source Zone enabled
  7. account service on AD with the differents rights : events log reader, user domain, server operators, Users of the com modele distributed.

When i verify the user mapping with this command : show user ip-user-mapping all,  only the Ip address is displayed but the user and From tab are empty.

Can anybody tell why the mapping isn't working ? How to resolve this issue ? help 

2 REPLIES 2

L2 Linker

Hi there, it's been a while, did you get this resolved?

If so, what was your solution?

 

If not, can you test your server profile by running the commands in the below resource (step 2)?

https://docs.paloaltonetworks.com/pan-os/9-1/pan-os-cli-quick-start/use-the-cli/test-the-configurati...

You should get a successful authentication if the authentication and server profiles are working.


Also, under device > user identification > user mapping, what do you see under the "status" column for "server monitoring"? It should show a green "Connected".

Lastly, in your authentication profile, what do you see in the "Advanced" tab > Allow list? 

Cyberforce Commander.
Don't forget to hit that Like button if a post is helpful to you!

Cyber Elite
Cyber Elite

As @Gustavo_Aristi  has provided you some great info, I will add that WMI protocol is used for IP address to user mapping not LDAP, so if you are not using the Palo Alto agent see below:

 

 

How to Configure Agentless User-ID - Knowledge Base - Palo Alto Networks

 

Server Monitor Account (paloaltonetworks.com)

 

How To Verify WMI Remote Connectivity using WBEMTEST (paloaltonetworks.com)

 

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClsrCAC

 

Agentless User-ID Error failed to parse security log buf - Knowledge Base - Palo Alto Networks

 

 

 

 

Sometimes the agent is better as to not cause CPU load and in some cases the server team may not allow non Microsoft devices to connect to the AD server:

 

 

Configure the Windows-Based User-ID Agent for User Mapping (paloaltonetworks.com)

 

 

 

 

Also when you get this done you could be interested in redistributing this info to other firewalls:

 

LIVEcommunity - Knowledge sharing: IP and user TAG Mappings redistribution for DAG / DUG - LIVEcommu...

 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!