GlobalProtect HIP issues

cancel
Showing results for 
Search instead for 
Did you mean: 

GlobalProtect HIP issues

L2 Linker

Hello,

 

 I am testing out using HIP match for certain traffic but I am running into an issue where traffic continues to be blocked.  I can see the HIP information in the log and firewalls has GP Gateway license.  Originally tried to use HIP for just Anti-Malware 'Is Installed' and has 'Real Time Protection' and the traffic never passed even though in the HIP log I can see both of these being good.  So then I just tried to use host information and host contains "Microsoft" (I am using a Windows 10 machine to test) and again traffic fails despite the HIP log showing the machine is Windows 10.  If I remove the HIP profile from the security policy, the traffic passes without issue.  

 

  I have now tested with different categories in the HIP object, testing different client machines to see if something was unusual but it doesn't matter, if the HIP Profile is in use, traffic is blocked.  

 

  Is anyone familiar with what might cause the HIP information to match but traffic still not pass as expected?  

 

Thank you. 

1 ACCEPTED SOLUTION

Accepted Solutions

Hello,

 

 Turns out there's a key part of using HIP matching that should probably be mentioned first instead of buried deeper in articles; you need to have User-ID enabled on the zone.  Once that was enabled it worked fine. 

View solution in original post

2 REPLIES 2

Cyber Elite
Cyber Elite

What GlobalProtect agent and PAN-OS version are you running? Might help to also share how you have the security rulebase entry configured, because this should work without issue as long as your HIP profile is being matched properly on the client in question. 

Hello,

 

 Turns out there's a key part of using HIP matching that should probably be mentioned first instead of buried deeper in articles; you need to have User-ID enabled on the zone.  Once that was enabled it worked fine. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!