Expedition hangs on Generating Profiles vsys/dg:vsys1

cancel
Showing results for 
Search instead for 
Did you mean: 

Expedition hangs on Generating Profiles vsys/dg:vsys1

L0 Member

I have created two projects - one works fine - I can run the Best Practise app, and call also generate the xml files. The other hangs whilst trying to generate Profiles vsys/dg:vsys1.

 

The errors are as follows:

 

expedition@Expedition:/tmp$ cat error

 

Warning: simplexml_load_string(): Entity: line 12: parser error : Extra content at the end of the document in /var/www/html/libs/common/xml/panosxml.php on line 1601

 

Warning: simplexml_load_string():     </profile-group> in /var/www/html/libs/common/xml/panosxml.php on line 1601

 

Warning: simplexml_load_string():     ^ in /var/www/html/libs/common/xml/panosxml.php on line 1601

 

Warning: get_class() expects parameter 1 to be object, boolean given in /var/www/html/libs/xmlapi.php on line 1838

object(SimpleXMLPHP Fatal error:  Uncaught Except

Fatal error: Uncaught Exception: Wrong type of input parameters, expected SimpleXMLElement key:value: in /var/www/html/libs/xmlapi.php:1857

Stack trace:

#0 /var/www/html/libs/common/xml/panosxml.php(1602): SimpleXMLElement_append(Object(SimpleXMLElement), false)

#1 /var/www/html/bin/configurations/output/output_function.php(289): xml_profiles_groups(Object(SimpleXMLElement), Array, Array)

#2 /var/www/html/bin/configurations/output/output_function.php(25): generate_xml(Array, '3')

#3 {main}

  thrown in /var/www/html/libs/xmlapi.php on line 1857

 

Can anyone assist here? I dont want to have to spend weeks re-creating the project, so any help or advise is most gratefully received.

 

Many thanks,

 

Neil

2 REPLIES 2

L1 Bithead

Hello,

 

I am having similar issue, were you able to get around it?

 

Thanks. 

L0 Member

Hi there,

 

Yes - we did resolve it. Remove all the profiles, such as ZPP, Logging, etc, that you have created in Expedition, and then click generate - it should work. You have to add the profiles on the firewalls themselves, rather than using Expedition to do so.

 

Yet another issue with Expedition - I am wondering if it is worth using at all. There are so many issues with it,

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!