Not getting output in Jira

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements

Not getting output in Jira

L2 Linker

Hi All,

I have added a custom field in jira (MITRE Tactic). I have mapped this field in XSOAR with 2 fields: Mitre Tech ID(short text type) and MITRE Technique ID(Multi select / Array).

Below is the command I was using and the output I was getting:

"customfield_11503": "${incident.mitretechid}"${incident.mitretechniqueid}

"customfield_11503": ""["T1651"]

 

If I am using this command 

{"fields":{"customfield_11503":{"value": "${incident.techniqueid}"}}}

{"fields":{"customfield_11503":{"value": "["T1651"]"}}}

I am getting error

Himangi_0-1693553691213.png

 

I have tried multiple combinations by removing comma adding space everything still giving this error.

I tried using both the fields, for short text type, it is not fetching any result in XSOAR whereas If I am using the array one I can see the id in XSOAR but it is giving me error and hence the value is not getting printed in JIRA.

Please can you assist where I am going wrong, I have tried multiple combinations.

Thanks in advance.

1 REPLY 1

L5 Sessionator

Hi @Himangi, you need to escape the inner quotes. When you do this via UI, XSOAR will automatically add the escapes.

 

{"fields":{"customfield_11503":{"value": "["T1651"]"}}} Should be {"fields":{"customfield_11503":{"value": "[\"T1651\"]"}}}

  • 853 Views
  • 1 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!