Expedition Merge and Generate XML not working

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements

Expedition Merge and Generate XML not working

L1 Bithead

Hi, 

 

After trying and failing on Expedition 1.0.95 with no luck I have now deleted my VM and downloaded and updated to 1.0.107.

 

Whenever I migrate (tried Cisco, Checkpoint and Juniper), I click export, drag the elements into the base config, press merge then generate xml. I'm left with what looks like the original base config instead of a xml output.

All the migrated work is lost.

 

What is the sequence from when I am ready to generate an xml?

 

By the way the configs and base config are fine as I've used them before in the Migration Tool 3.3.15

 

Thanks

20 REPLIES 20

L3 Networker

Sorry if this is an obvious question, but are you importing a base config in addtion to your Cisco?  When you export, before you drag from the left to the right, do you see your new base config or is it blank?

L7 Applicator

Is the TASK MANAGER UP? From the main Dashboard...

yes I import a base config and then the Cisco config.

 

Once i've finished all the cleanup (interfaces, services etc) I drag elements into the base coinfig and i actually see them in a pending state. Once I click merge the elements I moved over disappear and the base config is back to normal.

Yes, when I login in I press start so it runs jobs in the background.

Then if you select from now as a source your base config from the bottom right combo box the policies and objects are shown now under the base config right? The problem is at the time to generate the XML then? If yes, can you check the file

 

tail -f /home/userSpace/panReadOrders.txt ?

It seems as though there is no such file or directory when I run this command.tail.PNG

Thought it might be useful to show the merging process I am doing. Of course I am starting to task manager first before entering a project.stage 1stage 1stage 2stage 2stage 3stage 3stage 4stage 4stage 5stage 5

Have you found a resolution to this? I am having the same issue.

Thanks,

Is it just the XML download or the same with the .zip file?

It is the case for both the XML and the ZIP for me. When I open up the XML, it looks like 1 line from each section has been imported. For example, eth1/1 was created but not the rest of the interfaces. The first gateway and ipsec objects are in the XML but not the full list I am expecting. Same with security rules, only the first line is shown in the XML. I assume expedition is hitting some kind of error in each section and skipping to the next section.

Hi,

 

Would it be possible to export this project having issues and send it to fwmigrate at paloaltonetworks dot com for further research?

We have not experienced this issue, and it may be a corner case that we would like to study to address it.

 

Best,

Sorry about the delay.

 

I blew the VM back in October as Palo Alto now have a higher version to download. I'm on 1.0.107 now, which I belive was a fresh download then one update.

 

So far it seems to be ok but I've only tested it with 1 Cisco config (the exact same one it wouldn't work with before) and one Checkpoint.

 

What version are you on?

You are the best 🙂

hey i have the same problem!!

how did u download the earlier version..

i cant do nothing now 

 

someone?

expedition.PNG

  • 17682 Views
  • 20 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!