Captive portal not working in Chrome and Edge after updating to PAN OS 10.1.2

Showing results for 
Search instead for 
Did you mean: 

Captive portal not working in Chrome and Edge after updating to PAN OS 10.1.2

L4 Transporter

Hi All,


I have an issue where captive portal isn't working in Chrome 92.0.4515-159 and Edge 92.0.902.84 after updating to PAN OS 10.1.2. Captive portal is still working in IE 11 and Firefox 91.0.2 though.


Receiving the below error in Chrome and a similar error in Edge:


Has anyone come across this issue? It seems as though it may be a bug? Any ideas?


Before doing the command, PAN TAC advised that since service route was going through the management interface, they advised me to enable User-ID in the MGT interface but unfortunately, still the same issue . Then comes the command to disable the token in the Captive Portal and it worked.

L4 Transporter

Thanks @Nikko.Junia, so you can confirm that Chrome/Edge work with captive portal in PAN OS 10.1.2?

L4 Transporter

@Nikko.Junia @BPry turns out the below command hadn't been run successfully by the client. I logged in and ran it, to triple check, and the issue is now resolved.



#set deviceconfig setting captive-portal disable-token


Cyber Elite
Cyber Elite

Nice! It seems that other captive portals like Cisco Wi-Fi ones have this issue with the new edge and chrome as I was thinking it was Globalprotect VPN having issues but it is not.

L3 Networker

Hi Team,


After implementing the below command do we need to re-boot the firewall 



#set deviceconfig setting captive-portal disable-token



I had upgraded the device recently to 10.1.0 and facing the same issue even after running the above command.


Any thoughts on this.


@Nikko.Junia @Ben-Price 

I tried to run this command several times. I still get no results and I keep seeing the same screen on chrome

Hi @WithineyMelo  What Pan-OS version you are using

The firewalls were running on 10.0.8-h4, but I upgraded them to 10.1.3 to see if it could fix the issue. And so far, I keep seeing that screen on both Chrome and Edge. Now they're running on 10.1.3

L0 Member

Hi guys,

In my firewall (PA-850, version 10.0.8-h4, the command looks like this: set deviceconfig setting captive-portal disable-token yes

So, does the disable-token parameter have to be no or yes for the captive portal to work in a browser like Google Chrome?


configure showconfigure show


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!