Expedition 1.1.83 hangs during xml export

Showing results for 
Search instead for 
Did you mean: 
We are conducting regularly scheduled maintenance over the weekend, which could cause some downtime on LIVEcommunity. We apologize for any inconvenience.

Expedition 1.1.83 hangs during xml export

L1 Bithead

I'm trying to complete a cisco ASA to Palo Alto migration but Expedition seems to hang during the generation of the xml output. I've restarted jobs and task manger multiple times as well as updating Expedition and rebooting the vm itself. Below is the output from the "cat /tmp/error" command via cli.

expedition@Expedition:~$ cat /tmp/error

Notice: Undefined variable: service2 in /var/www/html/libs/common/xml/panosxml.php on line 2611

Fatal error: Uncaught Error: Call to a member function addChild() on null in /var/www/html/libs/common/xml/panosxml.php:2611
Stack trace:
#0 /var/www/html/bin/configurations/output/output_function.php(326): xml_address_groups(Object(SimpleXMLElement), Array, Array)
#1 /var/www/html/bin/configurations/output/output_function.php(25): generate_xml(Array, '26')
#2 {main}
thrown in /var/www/html/libs/common/xml/panosxml.php on line 2611
ne 2611


Any help with this issue will be greatly appreciated.



Cyber Elite
Cyber Elite

Hi Joe


I am not able to confirm your issue.  I just now upgraded to the latest Expedition, and am working on a Cisco migration, and the tool worked without issue.  It sounds like something may not have gone right with your upgrade.


Let me know if you can try to reinstall Expedition, or perhaps kept a snapshot of 1.1.82 to confirm if the issue is with the Tool or the upgrade.

Help the community: Like helpful comments and mark solutions

In addition, may I recommend that you post your query under:





Help the community: Like helpful comments and mark solutions

Thanks, will do.

The error mentions "xml_address_groups" and I'm wondering is there something wrong with one of my address group but nothing stands out to me.

L1 Bithead



I have the same identical issue, both ASA, but im on 1.1.88


but instead of objects, i got the tags. 

I was able to resolve my issue by just starting a new project. I mirrored everything I did a different project and it seemed to correctly and not hang.


Hope this helps.

L1 Bithead


Redoing the Project did not help in my case, but it worked if i deleted the tags. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!